Somme sous condition de date

Signaler
Messages postés
236
Date d'inscription
dimanche 4 janvier 2015
Statut
Membre
Dernière intervention
9 février 2021
-
Messages postés
615
Date d'inscription
jeudi 18 juillet 2019
Statut
Membre
Dernière intervention
25 février 2021
-
Bonjour,
J'ai un petit problème je voudrai faire la somme de valeurs sous condition de dates et de semaines
Cellule B22 = le numéro de semaine 1ou 2 ou 3 ou 4 ou 5
Colonne E de E5 à E48 les dates sous forme 01/02 jour/mois
Colonne H de H5 à H48 les valeurs pour en faire la somme
Je voudrai faire la somme des valeurs de la colonne H en fonction des dates de la semaine 1 ou 2 etc..
Avec la fonction SOMME.SI.ENS mais je galère et ne trouve pas l’erreur
=SOMME.SI.ENS(H5:H48;E5:E48;29/1:28/2;B22;"4") EXCEL me répond « Valeur »

Un grand merci pour la réponse
Cordialement



Configuration: Windows / Chrome 88.0.4324.146

2 réponses

Messages postés
1417
Date d'inscription
samedi 2 février 2019
Statut
Membre
Dernière intervention
25 février 2021
145
Bonsoir,

est-il nécessaire de prendre en considération les dates en colonne E ?

Puisque vous dites vouloir faire la somme de la colonne H suivant le numéro de semaine en cellule B22.
Messages postés
236
Date d'inscription
dimanche 4 janvier 2015
Statut
Membre
Dernière intervention
9 février 2021

Bonsoir,

je pense qu'il est nécessaire car en B22 j'ai uniquement un nombre qui représente le nombre restant de semaine dans le mois.
Messages postés
1417
Date d'inscription
samedi 2 février 2019
Statut
Membre
Dernière intervention
25 février 2021
145 >
Messages postés
236
Date d'inscription
dimanche 4 janvier 2015
Statut
Membre
Dernière intervention
9 février 2021

J'ai du mal à comprendre ce que vous cherchez à faire, précisément !

Il faudrait m'en dire un peu plus.
Messages postés
236
Date d'inscription
dimanche 4 janvier 2015
Statut
Membre
Dernière intervention
9 février 2021
>
Messages postés
1417
Date d'inscription
samedi 2 février 2019
Statut
Membre
Dernière intervention
25 février 2021

Je cherche à faire le total de mes dépenses par semaine et de le déduire de mon budget à la semaine. Ce n'est peut être pas la bonne fonction.


Cordialement
Bonjour,
Vous pourriez voir ce petit exemple :
https://cjoint.com/c/KBfmgu8taia
Cordialement.
Messages postés
236
Date d'inscription
dimanche 4 janvier 2015
Statut
Membre
Dernière intervention
9 février 2021

Bonjour,
dans mon tableur j'ai la fonction =maintenant() et je voulais m'en servir pour déterminer mes semaines avec la fonction si mais je n'arrive pas à rédiger la formule qui va bien du style pour la semaine 1 du mois de telle date à telle date calcul le budget moyen etc ... =SOMME.SI.ENS(H5:H48;E5:E48;29/1:28/2;B22;"4") excel m affiche "valeur"
Je n'arrive pas à trouver pourquoi et où se trouve l erreur
Drs fois que
Cordialement et encore merci de l'aide
Messages postés
615
Date d'inscription
jeudi 18 juillet 2019
Statut
Membre
Dernière intervention
25 février 2021
42 >
Messages postés
236
Date d'inscription
dimanche 4 janvier 2015
Statut
Membre
Dernière intervention
9 février 2021

Bonjour,

Pour cela il faut que tu aies quelque part les jours de début et fin de semaine
=SOMME.SI.ENS(H5:H48;E5:E48;">="&cellule premier jour semaine";E5:E48;"<="&cellule dernier jour semaine")
ou que tu aies directement le numéro de semaine dans une colonne de ton tableau ton tableau.

Sans exemple de ton fichier, difficile de te conseiller.

Cordialement