Probleme #ref avec recherchev [Résolu]

Signaler
Messages postés
35
Date d'inscription
lundi 20 avril 2020
Statut
Membre
Dernière intervention
28 novembre 2020
-
Messages postés
35
Date d'inscription
lundi 20 avril 2020
Statut
Membre
Dernière intervention
28 novembre 2020
-
Bonjour à tous,

je suis confronté à un problème qui commence à me chatouiller.
je tape la formule
=RECHERCHEV(B29;ville1;ville0;0)

en C30 pour remplir automatiquement le code postal d'une ville renseigné en B29
VILLE1 correspond a la liste des villes
et
VILLE0 correspond a la liste des codes postaux
mais j'ai une erreur #ref

si quelqu'un a une petite idée
merci

4 réponses

Messages postés
2313
Date d'inscription
lundi 2 juillet 2018
Statut
Membre
Dernière intervention
17 mai 2021
401
Bonjour,
Un exemple de votre fichier avec explications serait le bienvenu.
Pour transmettre un fichier,
Veillez à ce qu'il n'y ait PAS DE DONNEES CONFIDENTIELLES
il faut passer par un site de pièce jointe tel que cjoint.com

Allez sur ce site : https://www.cjoint.com/
Clic sur parcourir,
Cherche ton fichier,
clic sur ouvrir,
Clic sur "Créer le lien cjoint",
Copier le lien,
Revenir ici le coller dans une réponse...
Cordialement

Messages postés
35
Date d'inscription
lundi 20 avril 2020
Statut
Membre
Dernière intervention
28 novembre 2020

https://www.cjoint.com/c/JKwnyMfTfR0
merci
Messages postés
2453
Date d'inscription
vendredi 25 juillet 2014
Statut
Membre
Dernière intervention
14 mai 2021
1 109
Bonsoir
La fonction RECHERCHEV cherche la donnée dans la 1ére colonne et la correspondance dans la colonne indiquée dans l'avant dernier argument
donc ici les colonnes de la feuile 2 sont inversées
il vaut mieux utiliser les fonctions INDEX et EQUIV
=INDEX(ville0;EQUIV(B6;ville1;0);1)
Messages postés
35
Date d'inscription
lundi 20 avril 2020
Statut
Membre
Dernière intervention
28 novembre 2020

merci
marche parfaitement