Formule condition Si ET OU... [Résolu]

Signaler
-
Messages postés
2881
Date d'inscription
dimanche 3 mai 2009
Statut
Membre
Dernière intervention
20 novembre 2020
-
Bonjour à tous,

je reviens vers vous parce que je peine à établir ma formule.

Je souhaiterais que quand :

1/la cellule A est égale à "PM" et que la cellule B est égale à "P" ou "M" alors affiché "oui"
2/mais quand la cellule A est égale à "GP" et que la cellule B est égale à "G" ou "P" alors affiché "oui"
3/mais quand la cellule A est égale à "GP2" et que la cellule B est égale à "G" ou "P2" alors affiché "oui"
4/mais quand la cellule A est égale à "G2P" et que la cellule B est égale à "G2" ou "P" alors affiché "oui"
5/si les précédentes conditions ne sont pas remplies alors laisser la cellule vide. En fait, il faut que ces conditions soient remplies sinon ne rien afficher. Et si (par exemple) la cellule A est égale à PM et que la cellule B est égale à G ou P, cela n'est donc pas correct et donc ne rien afficher non plus.

Je ne sais pas si je m'exprime bien. Je ne veux pas que si la cellule A est égale à "PM" ou "GP" ou "GP2" ou G2P" alors = oui. Non non ce sont des conditions bien distinctes les unes des autres.

Pour résumé :

si A="PM" et si B="P" ou M" alors "oui"
si A= "GP" et si B="G" ou "P" alors "oui"
si A="GP2" et si B="G" ou "P2" alors "oui"
si A="G2P" et si B="G2" ou "P" alors "oui"
si ces conditions sont non remplies alors "rien" et si A est vide (pas encore remplie) alors idem, "rien"

J'ai pensé à la fonction "si ou" mais vu mes très faibles connaissances, je n'y arrive pas (d’où mon pseudo)...

D'avance un grand merci à ma/mon/mes sauveurs

Configuration: Windows / Firefox 68.0

5 réponses

Messages postés
2881
Date d'inscription
dimanche 3 mai 2009
Statut
Membre
Dernière intervention
20 novembre 2020
776
Bonjour

SI.CONDITIONS() n'est que sur la dernière version d'Excel.

Cette formule à essayer - chez moi elle fonctionne

=SI(A1<>"";SI(OU(ET(A1="pm";OU(B1="p";B1="m"));ET(A1="gp";OU(B1="g";B1="p"));ET(A1="gp2";OU(B1="g";B1="p2"));ET(A1="g2p";OU(B1="g2";B1="p")));"OUI";"");"")


Cordialement
>
Messages postés
45
Date d'inscription
samedi 7 novembre 2020
Statut
Membre
Dernière intervention
20 novembre 2020

(si je me suis trompé de section, je m'en excuse)
Messages postés
45
Date d'inscription
samedi 7 novembre 2020
Statut
Membre
Dernière intervention
20 novembre 2020
9 > Top_nullissime
Pas de souci : l'essentiel c'est que vous avez une réponse à votre question.
La solution de PapyLuc51, c'est celle que je voulais éviter en proposant plutôt SI.CONDITIONS
Messages postés
2881
Date d'inscription
dimanche 3 mai 2009
Statut
Membre
Dernière intervention
20 novembre 2020
776 >
Messages postés
45
Date d'inscription
samedi 7 novembre 2020
Statut
Membre
Dernière intervention
20 novembre 2020

Je n'avais pas fait gaffe à la rubrique qui englobe aussi bien OpenOffice que LibreOffice et c'est noté nul part qu'il s'agit de LibreOffice.
Je suis pas sur qu'elle existe sur OpenOffice.

Cordialement
Messages postés
45
Date d'inscription
samedi 7 novembre 2020
Statut
Membre
Dernière intervention
20 novembre 2020
9 >
Messages postés
2881
Date d'inscription
dimanche 3 mai 2009
Statut
Membre
Dernière intervention
20 novembre 2020

Je confirme : elle est absente d'OpenOffice qui a 10 ans de retard maintenant.
Cordialement
Messages postés
2881
Date d'inscription
dimanche 3 mai 2009
Statut
Membre
Dernière intervention
20 novembre 2020
776 >
Messages postés
45
Date d'inscription
samedi 7 novembre 2020
Statut
Membre
Dernière intervention
20 novembre 2020

C'est bien pour ça que je suis passé à LibreOffice.
C'est la première fois que j'utilise la formule SI.CONDITIONS.
Je la livre pour correction s'il en faut une

=SIERREUR(SI.CONDITIONS(A1="";"";ET(A1="pm";OU(B1="p";B1="m"));"OUI";ET(A1="gp";OU(B1="g";B1="p"));"OUI";ET(A1="gp2";OU(B1="g";B1="p2"));"OUI";ET(A1="g2p";OU(B1="g2";B1="p"));"OUI");"")

J'ai ajouté le sierreur pour éviter le #N/A lorsque les conditions ne sont par remplies

Cordialement
Messages postés
2194
Date d'inscription
vendredi 25 juillet 2014
Statut
Membre
Dernière intervention
20 novembre 2020
903
Bonjour
une autre proposition

avec en C2
=SI(NB.SI($H$2:$H$9;A2&B2)=1;"OUI";"")
Messages postés
45
Date d'inscription
samedi 7 novembre 2020
Statut
Membre
Dernière intervention
20 novembre 2020
9
Bonjour,
Pour la première ligne et à adapter pour les autres, ça peut donner :
=SI(A="";"rien";SI(ET((A="PM");OU(B="P";B="M"));"oui";"rien"))

Il y a peut-être plus élégant mais ça devrait marcher.
Bonjour,

oui ça fonctionne. Mais comment faites-vous pour mettre les autres conditions dans cette même formule ? pouvez-vous juste me montrer en incluant la 2ème condition et je pourrais continuer pour les autres ensuite (enfin je pense). Il n'y a pas de "et" ou de "où" à inclure pour la suite ?

Merci
Messages postés
45
Date d'inscription
samedi 7 novembre 2020
Statut
Membre
Dernière intervention
20 novembre 2020
9
Si on doit mettre toutes les conditions dans une seule et même formule, ça va faire quelque chose de compliqué à suivre.

Vous devriez regarder l'aide pour SI.CONDITIONS qui répondra sans doute mieux à la situation.

Je n'ai pas le temps de m'y pencher pour l'instant : vous aurez peut-être une autre réponse entre temps. Je pense aussi que ce type de problème a été traité récemment sur le forum : vous devriez utiliser la recherche pour vous en assurer.

merci de votre réponse ;-)