Formule si trop compliquée pour moi :-(

Résolu/Fermé
Signaler
-
Messages postés
3152
Date d'inscription
samedi 16 février 2019
Statut
Membre
Dernière intervention
6 décembre 2021
-
Bonjour,

voici ce que j'aimerais obtenir :
si A1= "PMG" ou "PGM" alors B1="PM" mais si A1= "MGP" ou "GMP" alors B1="GP" mais si A1= "PGP" alors B1="GP2" mais si A1= "PGG" alors B1="PG1" et enfin si A1= "AUTRES" alors B1="RIEN"


PMG ou PGM = PM
MGP ou GMP =GP
PGP= GP2
PGG=PG1 
AUTRES=RIEN

D'avance un grand merci à mon/ma sauveur

2 réponses

Messages postés
3152
Date d'inscription
samedi 16 février 2019
Statut
Membre
Dernière intervention
6 décembre 2021
698
Bonjour,

C'est un peut lourd, mais vous pouvez imbriquer des "SI" comme ceci:

=SI(OU(A1="PMG",A1="PGM"),"PM",(SI(OU(A1="MGP",A1="GPM"),"GP",(SI(A1="PGP","GP2",(SI(A1="PGG","GP1","RIEN")))))))


Il faut juste faire attention avec toutes les parenthèses, mais y'a rien de compliqué ;)

C'est une structure en SI(ValeurVraie, Alors ceci, (sinon si deuxième valeur, alors cela, (etc ...)))

Cdlt
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 41989 internautes nous ont dit merci ce mois-ci

Merci de votre réponse. ça ne fonctionne pas malheureusement. Vous êtes sûr de vos virgules ce ne sont pas des points virgule ? même en remplaçant y a quelques erreurs...je ne comprend pas bien ou est l'erreur

EDIT : c'est bon j'ai trouvé, merci beaucoup pour votre réponse vous me sauvez !
Messages postés
3152
Date d'inscription
samedi 16 février 2019
Statut
Membre
Dernière intervention
6 décembre 2021
698 > Top_nullissime
Ha, c'est vrai que j'ai peut-être changé les séparateurs sur mon PC pour un autre besoin :p
Messages postés
1595
Date d'inscription
samedi 2 février 2019
Statut
Membre
Dernière intervention
25 novembre 2021
171
Bonjour,

=SI(OU(A1="PMG";A1="PGM");"PM";SI(OU(A1="MGP";A1="GMP");"GP";SI(A1="PGP";"GP2";SI(A1="PGG";"PG1";""))))


;""))))
à remplacer par
;"RIEN"))))
s'il le faut

1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 41989 internautes nous ont dit merci ce mois-ci