Compter les séries de doublons de 1 à 12 par ordre croissant dans chaque cellule

Signaler
-
Messages postés
12847
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
16 novembre 2020
-
Bonjour,

Horizontalement j’ai une série de chiffres identiques par ordre croissant dans les cellules Excel de 1 jusqu'à 12
Exemple :
1;1;1;1;1;1;12;2;2;2;3;3;3;3;3;4;4;4;4;5;5;5;5;6;6;6;6;6;7;7;7;7;8;8;8;8;8;8;9;9;9;9;10;10;10;11;11;12;12

A l’aide d’une formule, je souhaiterai compter par ordre croissant automatiquement ces séries de chiffres de cette façon suivante si c’est possible ? (voir ci-dessous)

1;1;1;1;1;1;2;2;2;2;3;3;3;3;3;4;4;4;4;5;5;5;5;6;6;6;6;6;7;7;7;7;8;8;8;8;8;8;9;9;9;9;10;10;10;11;11;12;12
1;2;3;4;5;6;1;2;3;4;1;2;3;4;5;1;2;3;4;1;2;3;4;1;2;3;4;5;1;2;3;4;1;2;3;4;5;6;1;2;3;4; 1 ; 2 ; 3 ; 1 ; 2 ; 1 ; 2

J’espère avoir était clair

En vous remerciant



Configuration: Android / Chrome 81.0.4044.138

7 réponses

Messages postés
23640
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
16 novembre 2020
6 467
Bonjour,

avec une colonne A vide (pour avoir la même formule partout, sinon remplacer la 1ère par 1) et tes nombres commençant en B2, mettre en B3 :
=SI(A2=B2;A3+1;1) 

et tirer vers la droite.
eric

En essayant continuellement, on finit par réussir. 
Donc plus ça rate, plus on a de chances que ça marche.(les Shadoks)
En plus du merci (si si, ça se fait !!!), penser à mettre en résolu. Merci
Ok ca marche très bien.
Maintenant je souhaiterai savoir s'il est possible de rajouter une couleur Rouge et noire pour différencier les séries ?
Exemple :
[1;2;3;4;5;6];[1;2;3;4];[1;2;3;4;5];[1;2;3;4];[1;2;3;4];[1;2;3;4;5];[1;2;3;4]
Rouge Bleu Rouge Bleu Rouge Bleu Rouge

En te remerciant
Messages postés
23640
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
16 novembre 2020
6 467
Pas bonjour non plus,

ma formule fait ce que tu as demandé.
Dépose un fichier avec ce que tu as fait
eric
Messages postés
3
Date d'inscription
lundi 16 novembre 2020
Statut
Membre
Dernière intervention
16 novembre 2020

Excuse-moi, Bonjour,
Cette fois-ci je souhaiterai savoir s'il est possible dans ta formule que tu m'as donné (=SI(A2=B2;A3+1;1) et qui fonctionne parfaitement, insérer une couleur pour différencier les séries. Une série en rouge, puis une série en bleu, puis une série en rouge, une série en bleu etc..

Ps: je ne sais pas comment déposer un fichier Excel ? par-contre je t'ai envoyé une capture d'écran du fichier.

En te remerciant
Messages postés
23640
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
16 novembre 2020
6 467
toute la série ça me parait compliqué.
Le début de chaque est simple.
Sélectionner les cellules et mettre une mise en forme conditionnelle sur 'Egal à ...'
1

Poiur déposer un fichier : cjoint.com et coller le lien fourni ici
Messages postés
3
Date d'inscription
lundi 16 novembre 2020
Statut
Membre
Dernière intervention
16 novembre 2020
>
Messages postés
23640
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
16 novembre 2020

Eric ci-joint le fichier.. Merci

https://www.cjoint.com/c/JKqplXT6tby
Messages postés
12847
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
16 novembre 2020
2 064
Bonjour à vous deux

Coloration possible par MFC
Mettre toute la ligne 3 en bleu
Sélectionner la plage en ligne 3 avec toutes les valeurs et commençant en B3
MFC _ Nouvelle règle _ Utiliser une formule ...
Entrer la formule :
=EST.IMPAIR(NB.SI($B$3:B3;1))
Choisir le format de couleur rouge

Cdlmnt
Via
Messages postés
23640
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
16 novembre 2020
6 467
Bonjour via,

à condition que toutes les séries soient toujours présentes (?) Si c'est le cas c'est bon.
eric
Messages postés
12847
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
16 novembre 2020
2 064
@eriiic

Même s'il manque les 5 par exemple les séries seront bien colorées alternativement rouge bleu et c'est bien ce qui est demandé si je ne me trompe pas ?
Messages postés
23640
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
16 novembre 2020
6 467
Ah oui, j'avais mal analysé ta formule.
Très malin, bravo ;-)
Messages postés
12847
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
16 novembre 2020
2 064 >
Messages postés
23640
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
16 novembre 2020

Merci ☺
Messages postés
3
Date d'inscription
lundi 16 novembre 2020
Statut
Membre
Dernière intervention
16 novembre 2020

Bravo Eric et Via 55 vous faites 100% de réussite

J'ai d'autres demandes sur le même sujet (automatisation suivant des données variables) mais faut que je trouve les mots pour être le plus précis possible.

En vous remerciant
Messages postés
12847
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
16 novembre 2020
2 064
De rien

A plus