Bloquer une date heure

Signaler
-
Messages postés
2860
Date d'inscription
dimanche 3 mai 2009
Statut
Membre
Dernière intervention
15 novembre 2020
-
Bonjour,

je souhaiterais trouver une fonction ou script.
Pour que lorsque je clique sur une forme avec ce script ou cette fonction la date actuelle et heure actuelle se bloque dans une cellule choisi.
Car quand j'essaie en général a partir de la fonction now la date continue d'évoluer.
Ceci me servira pour créé des compte a rebours a partir de cette date figer auquel je rajouterais un certain délai (2jours en l'occurence)

Merci



Configuration: Macintosh / Safari 13.1.3

2 réponses

Messages postés
2860
Date d'inscription
dimanche 3 mai 2009
Statut
Membre
Dernière intervention
15 novembre 2020
773
Bonjour,

À voir si les réponses données >>>ICI<<< conviennent.

Cordialement
Bonjour Papy,
Le pb c'est que je suis sur googlesheet et que je ne maitrise pas le VBA.
Messages postés
2860
Date d'inscription
dimanche 3 mai 2009
Statut
Membre
Dernière intervention
15 novembre 2020
773 > Totor
Autant pour moi, je n'avais pas remarqué. Ne pas tenir compte, je quitte la discussion.

Cordialement
Messages postés
2860
Date d'inscription
dimanche 3 mai 2009
Statut
Membre
Dernière intervention
15 novembre 2020
773
Bonjour,

Finalement je reviens pour proposer une formule de calcul itératif - bon ce n'est pas en cliquant sur une forme mais en mettant un signe quelconque dans une cellule pour provoquer la fonction maintenant.

Il faut tout d'abord activer les calculs itératifs dans Fichier / Paramètres de la feuille de calcul - voir l'image ci-dessous.

Pour un " X " dans la cellule A1 la formule en B1
=SI(A1="";"";SI(B1<>"";B1;MAINTENANT()))


La date et l'heure seront fixées tant que la cellule A1 ne sera pas effacée - et il possible, dans une autre cellule, d'ajouter ou enlever des jours à la date.



En espérant que ça convienne.

Cordialement