Si cellule contient un mot alors

Signaler
-
Messages postés
894
Date d'inscription
lundi 22 septembre 2008
Statut
Membre
Dernière intervention
14 novembre 2020
-
Bonjour,

Ma colonne [@SERVICE] contient des références comme :
J-BE_DEVIS ou J-BE_PROJET

Nous savons grâce à cette colonne si nous parlons d'un devis ou d'un projet. J'aimerai créer une nouvelle colonne avec une formule reprenant les infos de la colonne [@SERVICE] mais que ce soit juste écrit projet ou devis, sans la notion "J-BE_".

Dans cette attente, bonne journée :).

Configuration: Windows / Chrome 86.0.4240.111

2 réponses

Messages postés
25544
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
13 novembre 2020
5 597
Bonjour
=STXT(A1;TROUVE("_";A1)+1;10)
ou
=SUBSTITUE(A3;"J-BE_";"")
crdlmnt

Messages postés
894
Date d'inscription
lundi 22 septembre 2008
Statut
Membre
Dernière intervention
14 novembre 2020
182
Bonjour,

Si il n'y a dans cette colonne que ces deux indications
=SI([@SERVICE]="J-BE_DEVIS";"devis";"Projet")


S'il y a d'autre indication alors
=SI([@SERVICE]="J-BE_DEVIS";"devis";SI([@SERVICE]="J-BE_PROJET";"Projet";""))