Cellule importée avec le signe négatif à droite

Signaler
-
 Thierry-du-56 -
Bonjour, j'ai un fichier PDF qui a été transformé en Excel. J'ai des nombres négatifs (format américain peut-être ?) qui sont écrit 1.92- au lieu de -1.92 et donc quand je les additionne cela ne fonctionne pas car il doit les considérer en format "texte". Le signe négatif sur le PDF était à droit et donc lors de l'export vers Excel il est resté à cette position. J'ai modifié le format de cellule, testé diverses choses, je ne trouve pas la solution.
Je n'ai pas envie de me retaper toutes ces modifications à la main.
Une macro serait bien je pense mais je n'ai pas d'idée.
Merci de m'aider

2 réponses

Messages postés
1222
Date d'inscription
samedi 2 février 2019
Statut
Membre
Dernière intervention
14 novembre 2020
121
Bonjour,

pour Excel, les . sont aussi considérés comme du texte.

Il faut les remplacer par des ,
Messages postés
30003
Date d'inscription
mercredi 2 mai 2007
Statut
Modérateur
Dernière intervention
14 novembre 2020
6 956
Bonjour,

On peut utiliser
=SI(DROITE(A1;1)="-";CNUM(SUBSTITUE(GAUCHE(A1;NBCAR(A1)-1);".";",")*-1))



Merci beaucoup pour votre rapidité à tous les deux, cela fonctionne parfaitement. J'ai juste complété la formule pour que je puisse l'adapter sur des chiffres positifs et des cellules vides. A savoir : =SI(D2="";"";SI(DROITE(D2;1)="-";CNUM(SUBSTITUE(GAUCHE(D2;NBCAR(D2)-1);".";",")*-1);D2))