Mise en forme conditionnelle [Résolu]

Signaler
-
 Hercules -
Bonjour,

J'utilise depuis peu la mise en forme conditionnelle que je trouve dingue en possibilité.

Je l'utilise pour plusieurs raisons. J'ai deux colonnes ou une couleur varie en fonction de la valeur.
colonne A : des valeurs qui vont de 50 à 60 dans le désordre
colonne B : des valeurs qui vont de -100 à 200 dans le désordre.
Un changement de couleur apparait sur mes 2 colonnes lorsque la colonne B a une valeur négative et lorsqu'elle change de valeur.
Exemple : Si ma colonne B a plusieurs -20 d'affilés, même couleur mais si elle passe à -9 autre couleur.

Ce que j'aimerais c'est pouvoir afficher en colonne C sur la même ligne la valeur qui change de la colonne B. Exemple 1 fois -20 et dès que la valeur passe à -9 une fois -9, etc..

Merci :)


Configuration: Windows / Edge 18.17763

4 réponses

Messages postés
25592
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
23 novembre 2020
5 615
Bonjour
MFC par formule:
=$B1<>$B2
et pour afficher le résultat en C si changement:
en C2
=SI(B2<>B1;B2;"")
crdlmnt



Merci pour votre réponse, c'est parfait !
J'aurais une seconde question, j'aimerais mettre plusieurs règles sur ces 2 colonnes, et l'une de ses règles serait, si une valeur est comprise entre 50 et 55 dans la colonne A et si une valeur est inférieur à 0 dans le colonne B, y affecter une couleur.

J'imagine qu'en passant par l'option "Appliquer une mise en forme uniquement aux cellules qui contiennent" ça devrait fonctionner, mais quelle formule appliquer ?

Merci encore
Messages postés
25592
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
23 novembre 2020
5 615
Re
votre question dit si SI entre 50 et 55 en A pour moins de 0 en B, et votre formule ne s'adresse qu'à B?
si on reprend mot pour mot ce que vous avez écrit,
  • sélection du champ à traiter ,qui, on suppose commence en ligne 1
  • MFC / Nouvelle règle / "utiliser une formule pour..."
  • entrer la formule dans la fenêtre affichée ,sans le SI

=ET($A1>=50;$A1<=55;$B1<0)
  • en respectant les positions des $

revenez en complétant vos explications si ça ne convient pas
crdlmnt
J'ai essayé ceci mais la formule contient une erreur apparemment :
=SI(ET(B1>=50;B1<=55))


Pour prendre en compte uniquement les valeurs entre 50 et 55.
C'est parfait, c'est exactement ce que je voulais, merci beaucoup !