Pb de lecture de certaines vidéos mp4 sur google drive

Signaler
Messages postés
75
Date d'inscription
dimanche 26 août 2012
Statut
Membre
Dernière intervention
9 juin 2021
-
Messages postés
20503
Date d'inscription
dimanche 9 septembre 2007
Statut
Contributeur
Dernière intervention
9 juin 2021
-
Bonjour,
Je stocke depuis plusieurs années des vidéos familiales sur google drive. Je constate que certaines vidéos ne peuvent pas être lues sur mon navigateur habituel Firefox, ni sur mon iphone 6 (safari). La première image s'affiche parfois, mais quand on essaie d'ouvrir la vidéo, c'est un cadre noir qui s'affiche.

J'ai fait les observations suivantes :
- la plupart des MP4 stockés sur Google Drive s'ouvrent normalement avec Firefox, ou sur mon iphone
- les vidéos qui bloquent sur firefox peuvent être lues avec les navigateurs Edge ou Chrome
- ces vidéos sont présentes sur le DD de mon ordinateur : si je les ouvre avec Firefox, elles sont lues normalement.
Mon ordinateur est sur windows 10 version 1909.
Que puis-je faire ? Merci de votre aide...
Mda

Configuration: Windows / Edge 85.0.564.51

14 réponses

Messages postés
20503
Date d'inscription
dimanche 9 septembre 2007
Statut
Contributeur
Dernière intervention
9 juin 2021
4 994
Normalement c'est fait par défaut... mais voici la manip:

Activer VLC

Ouvre le navigateur et clique sur les trois petits traits dans le coin supérieur droit de la page.

Clique sur "Modules complémentaires" dans la liste va sur "Extension".

Puis va dans la lucarne haut droit ... Tape VLC "Entrée"... il te soumet beaucoup de VLC

tu choisi "Open in VLC media player" OK... Il demande s'il faut ajouter à Fire Fox... oui, ...J'ai compris...

Normalement, après ça, c'est VLC qui lit tes vidéos dans FireFox... mais ça ne garanti pas que tes amis feront de même...

Il est donc possible aussi de reprendre tes vidéo à problème sur ton PC... de les réencoder et de les remettre ensuite sur "Google Drive" Après vérification que ça fonctionne...

Je te suggère le logiciel "AVIdemux 64" pour faire ce travail ..voir ici https://avidemux.fr.uptodown.com/windows performant et gratuit.

Voici un Tutoriel pour le guidage d'utilisation
https://www.tutoriels-video.fr/les-bases-du-montage-video-avec-avidemux/

Donc dans l'idée, tu reprends ta Vidéo... la réencode en MP4 AVC (x264)
en dessous clic sur "Configurer" ==>Général ... dans le caré Rate Control, tu change les valeurs Encoding mode: par "Average bit rate (two pass)"
Et "Average Bit Rate: par 2500


Tu ne change rien d'autre
pour l'audio, tu laisse Copy... pas de réencodage Audio

Il faut glisser déposer ta vidéo dans le rectangle de droite pour lancer le program

Ensuite tu clic sur la disquette de gauche en haut pour sauver ta vidéo modifiée selon les nouveaux reglages... il y a deux passes, mais pour trois minutes, ça ne doit pas durer bien longtemps...
Vérifie le résultat final.... Re-charge le sur Google Drive et verifie à nouveau le résultat... demande aussi à une autre personne de vérifier...

Voila, normalement tu as de quoi démarrer... pour corriger les vidéos converties de ton Sony..
Messages postés
6729
Date d'inscription
mercredi 8 juillet 2020
Statut
Membre
Dernière intervention
9 juin 2021
730
Bonjour,
Pour tes problèmes de lecture de fichier mp4 sur Google Drive, une explication ici... https://recoverit.wondershare.fr/video-repair/google-drive-not-playing.html?sscid=b1k4_milzl
Messages postés
20503
Date d'inscription
dimanche 9 septembre 2007
Statut
Contributeur
Dernière intervention
9 juin 2021
4 994
Bonjour,

Les vidéos de lisent avec VLC , c'est un logiciel pour lire les vidéos et il contient tous les "Codecs" voulus... et il s'intègre dans ton navigateur Web.
https://www.commentcamarche.net/download/telecharger-127-vlc-media-player

Le problème réside certainement dans le fichier Vidéo, sa source, son encodage etc... on ne peut pas savoir comme ça... il existe une multitude de vidéo qui semblent du même type... il n'en n'est rien... Les temps ayant changés, ce qui fonctionnait en l'an 2000 n'est pas forcément lu aujourd'hui.. par un navigateur WEB.

Voici le logiciel qu'il faut avoir https://mediaarea.net/fr/MediaInfo pour connaitre l'intérieur d'une vidéo...Et en partant de là, chercher à savoir ce que ça signifie... Et comprendre Pourquoi..??
Messages postés
75
Date d'inscription
dimanche 26 août 2012
Statut
Membre
Dernière intervention
9 juin 2021

Bonjour Jeannets, et merci de ta réponse.
J'avais déjà ces deux logiciels sur mon ordinateur. Avec Mediainfo, j'obtiens une description détaillée des vidéos à problème, mais comment interpréter ?
Messages postés
75
Date d'inscription
dimanche 26 août 2012
Statut
Membre
Dernière intervention
9 juin 2021

Encore une info : je viens d'ajouter dans Firefox le plugin Ouvrir avec Vlc, mais j'obtiens le même résultat avec les vidéos en cause.
Messages postés
20503
Date d'inscription
dimanche 9 septembre 2007
Statut
Contributeur
Dernière intervention
9 juin 2021
4 994
Et alors..?? la même vidéo lancée en lecture dans VLC (VLC à jour)... elle ne fonctionne pas non plus..??

Pour Média info...tu dois aller dans "windows explorer" chercher ton film... Clic droit dessus===>Mediainfo ==>Vue==>texte ...tu va voir du texte qui donne des renseignements sur ta vidéo... Tu le copie intégralement et le colle ici...

Il faudrait aussi la marque et le modèle de ton PC (sinon le modèle de sa carte mère)

Tu as du visualiser ces films autrefois...?? C'était avec quel modèle de PC et version de windows..?
Messages postés
75
Date d'inscription
dimanche 26 août 2012
Statut
Membre
Dernière intervention
9 juin 2021

1/ La même vidéo lue dans VLC fonctionne bien. On peut aussi la lire dans firefox si on ouvre le fichier mp4 résidant sur mon PC. Ce qui ne marche pas, c'est d'ouvrir dans firefox le fichier stocké sur Google Drive (alors que ce fichier sur Google Drive peut être lu sur Edge ou Chrome).
Ceci me fait penser que le pb n'est peut-être pas dans le fichier mp4 lui-même, mais dans la config de mon firefox ?

2/ Mon PC : ASUS
BU401LG-CZ033G Ci7-4500u
Acheté le 16/03/2015
windows 10 version 1909

3/ j'ai toujours pu lire ces vidéos sur mon pc, mais je viens de constater que la version postée sur Google Drive pour partager avec la famille, posait des pbs de lecture

4/ Voici le résultat de MediaInfo :
Général
Nom complet : E:\Google Drive\VideosGabin\Année-2017\2017_12\2017_12_17_Paris-MAH00060-H-4-unehistoire.mp4
Format : MPEG-4
Profil du format : Base Media / Version 2
Identifiant du codec : mp42 (mp41/isom)
Taille du fichier : 166 Mio
Durée : 3 min 13s
Débit global moyen : 7 221 kb/s

Vidéo
ID : 1
Format : AVC
Format/Info : Advanced Video Codec
Profil du format : Baseline@L4
Paramètres du format : 1 Ref Frames
Paramètres du format, CABAC : Non
Paramètres du format, RefFrames : 1 image
Paramètres du format, GOP : M=1, N=15
Identifiant du codec : avc1
Identifiant du codec/Info : Advanced Video Coding
Durée : 3 min 13s
Durée de la source duration : 3 min 13s
Débit : 7 020 kb/s
Largeur : 1 920 pixels
Hauteur : 1 080 pixels
Format à l'écran : 16/9
Type d'images/s : Constant
Images par seconde : 29,970 (29970/1000) Im/s
Espace de couleurs : YUV
Sous-échantillonnage de la chrominance : 4:2:0
Profondeur des couleurs : 8 bits
Type de balayage : Progressif
Bits/(Pixel*Image) : 0.113
Taille du flux : 162 Mio (97%)
Taille du flux source : 162 Mio (97%)
mdhd_Duration : 193427
Codec configuration box : avcC

Audio
ID : 2
Format : AAC LC
Format/Info : Advanced Audio Codec Low Complexity
Identifiant du codec : mp4a-40-2
Durée : 3 min 13s
Type de débit : Constant
Débit : 192 kb/s
Canaux : 2 canaux
Channel layout : L R
Echantillonnage : 48,0 kHz
Images par seconde : 46,875 Im/s (1024 SPF)
Mode de compression : Avec perte
Taille du flux : 4,52 Mio (3%)
mdhd_Duration : 193387
Messages postés
20503
Date d'inscription
dimanche 9 septembre 2007
Statut
Contributeur
Dernière intervention
9 juin 2021
4 994
OK, ton PC est bien capable de passer ces vidéos.

J'ai regardé ton fichier (via médiainfo) bon, il n'y a pas de loup caché dedans..
Je trouve le fichier un peu volumineux...166méga pour 3 minutes, ce n'est pas économe...
C'est la fréquence image (Frame rate) de 7020 kb/sc qui fait ça... moi, j'aurais mis la moité, entre 2500 et 3000, ça fait des fichiers plus petits et on déguste aussi bien pour une courte vidéo... Sauf si tu veux pousser la définition... mais bon, c'est un avis perso et ça ne dérange pas le bon fonctionnement...

Ces vidéos sont sur le Cloud Google; mais qui les a mis là, c'est toi..?? les a tu encodées toi même avant de les uploader...?

est-ce que ton FireFox est à jour... version 80.0.1 --- et VLC est à la version 3.0.11 "vetinari" et il possède un greffon pour Mozilla Fire Fox, il faut peut etre regarder tout ça, mettre à jour et redémarrer le PC.
Ceci dit, Chrome est le bébé préféré de Google et FireFox le vilain petit canard, ça peut entrer en ligne de compte...

Voici une vidéo cool https://youtu.be/NvR0BqIKhrs de la même durée qui fonctionne très bien sous FireFox avec VLC intégré suivant les dernières versions cité au dessus... Visualisée ainsi, c'est une forme de Streaming identique.

Tu peux aussi vider le cache de FireFox... selon ce qu'il contient, ça peut polluer ta vidéo..
Messages postés
75
Date d'inscription
dimanche 26 août 2012
Statut
Membre
Dernière intervention
9 juin 2021

Voici mes réponses :
- Mon Firefox et VLC sont bien à jour, en revanche je ne sais pas où vérifier que VLC possède un greffon pour Firefox ?
- Je peux effectivement sur mon ordinateur, lire les vidéos sur Chrome, mais elles sont sur Google Drive pour être partagées avec plusieurs autres utilisateurs : c'est ennuyeux que ceux qui ont Firefox ne puissent pas les lire
- je conviens qu'elles sont lourdes : en fait, je remarque que les vidéos à pb sont celles que j'ai faites avec une caméra Sony HDR-PJ410. Je les convertis moi-même en MP4 (souvent j'en assemble plusieurs), avec le logiciel Video Win Movie Maker, avant de les poster sur Google Drive.
- Comment puis-je les alléger en réduisant la fréquence d'image ? Ce logiciel permet-il de faire celà ?
Messages postés
75
Date d'inscription
dimanche 26 août 2012
Statut
Membre
Dernière intervention
9 juin 2021

Bonjour Jeannets,
Je n'ai pas réussi à me servir de Avidemux. Il n'est pas totalement intuitif, et j'ai fait plusieurs essais sans succès. J'ai l'impression d'avoir bien fait la config, puis je glisse ma vidéo dans le cadre, mais la conversion ne démarre pas. Je déclenche la conversion en cliquant sur le bouton en forme de disquette pour enregistrer. Quand je vérifie le bit rate, il n'a pas changé...

D'autre part, j'ai une information importante :
j'ai ouvert un des fichiers à problème, en accédant à Google Drive à partir de l'ordinateur de ma femme, avec Firefox (Samsung Galaxy Book 12) : le fichier est lu sans pb
Je pense donc que ce n'est pas forcément le fichier vidéo qu'il faut recoder :
- soit c'est le Firefox sur mon ordinateur qui est mal configuré
- soit c'est un pb sur l'ordinateur lui-même (saturation de mémoire ?)
Qu'en penses-tu ?
Messages postés
20503
Date d'inscription
dimanche 9 septembre 2007
Statut
Contributeur
Dernière intervention
9 juin 2021
4 994
OK,

Le firefox de ta femme est sur un smartphone, sous Android (pas windows) on ne peut pas comparer...

Il est possible que ce réencodage ne soit pas utile...(???)... il faudrait savoir si le cercle de tes amis la lise sans problème...? Dans ce cas on pourrait déduire que le problème de lecture n'existe que chez toi..?? Mais ça, on en sait rien.. Il faudrait le savoir...
Le problème des vidéos et autres pages web...C'est qu'elles doivent pouvoir etre liues par tout le monde...

-- Que l'ordinateur soit vieux ou jeune...
-- Qu'il aie beaucoup de mémoire ou pas beaucoup
-- Qu'il fonctionne sous Linux ou Android ou windows... entre XP et win10
-- Que son navigateur soit FireFox...Chrome...Opéra..et autres.

Voila posé le cahier des charges minimum... Mais on ne peut pas conclure qu'un system est en panne parce que ça marche sur un autre..

La conversion démarre après avoir placé ton film dans le cadre... ensuite, tu règle les paramètres d'encodage... et lorsque c'est OK, tu clic sur l'icon de la disquette de gauche... et ça démarre, un bargraph montre la progression du travail... il y en a deux successifs, la passe 1 et la passe 2

Voila en gros comment ça se passe, mais je t'ai joint un tutoriel... ça devrait aller.
Messages postés
75
Date d'inscription
dimanche 26 août 2012
Statut
Membre
Dernière intervention
9 juin 2021

Bon, je suis encore un peu dans le bleu. Pendant le WE, j'ai désinstallé puis réinstallé Firefox, mais ça n'a pas changé grand chose.
Curieusement, il y a des moments où le pb signalé ne se produit pas, on a l'impression que tout est revenu à la normale, puis ça recommence.
Je continue à explorer le pb, mais si je ne trouve pas de solution, je suis tenté d'abandonner et de passer sur Chrome, qui lit très bien toutes mes vidéos. J'aurai demain, accès à un ordinateur windows sur lequel je referai le test.
Je ne me lance pas pour l'instant dans la conversion des vidéos.
Je te tiens au courant.
Messages postés
20503
Date d'inscription
dimanche 9 septembre 2007
Statut
Contributeur
Dernière intervention
9 juin 2021
4 994
Il faut bien t'informer sur la lecture de ces vidéos dans ton cercle de relations. Car si Chrome pourrait etre une solution pour toi, ça ne résoud pas le problème de lecture chez tes amis ou relations.
Il faudrait que tes vidéos soient lisibles par tous les types de systèmes informatiques répandus.
Messages postés
75
Date d'inscription
dimanche 26 août 2012
Statut
Membre
Dernière intervention
9 juin 2021

Bonjour Jeannets,
Je ne sais pas pourquoi : j'ai répondu à ton message du 22/09, mais ma réponse n'apparait pas dans la discussion. J'ai dû faire une erreur.
Je te disais que mon essai sur mon ancien ordinateur windows+firefox n'avait pas été concluant, car c'est un windows xp. Je n'ai pas réussi à lire les vidéos, mais on ne peut rien en conclure.
D'autre part, j'ai réessayé de lire les mêmes vidéos qui me posaient pb sur mon ordinateur connecté à google drive, et là, ça marche ! Peut-être que la réinstallation de firefox sur mon ordi a fait du bien.
Merci de ton aide. Je crois que je vais arrêter de chercher... (d'ailleurs, je n'ai pas reçu de remontées négatives des participants).
Messages postés
20503
Date d'inscription
dimanche 9 septembre 2007
Statut
Contributeur
Dernière intervention
9 juin 2021
4 994
OK, en effet, certains messages disparaissent mystérieusement... ça m'arrive aussi parfois. Les serveurs de CCM peuvent etre fautifs...? mais nous aussi... on crois avoir validé... et puis..?? C'est pas certain..

Je crois aussi que la réinstallation de FireFox fut salutaire.

En tout cas merci pour ton retour d'infos...

Bonne route