3 variantes comment faire ? [Résolu]

Signaler
-
Messages postés
7
Date d'inscription
mardi 15 septembre 2020
Statut
Membre
Dernière intervention
16 septembre 2020
-
Bonjour,

J'ai 3 variante possible mais je m'en sort pas...
Si A est entre -300 et 300 alors c'est zéro
Si c'est pas compris dans cette tranche alors il faut retirer 300 qu'il soit négatif ou positif...
Quelqu'un peut m'aider svp...


Configuration: Android / Chrome 85.0.4183.101

6 réponses

Messages postés
12651
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
17 septembre 2020
2 008
Bonjour

=SI(ET(A1>-300;A1<300);0;A1-300)

Cdlmnt
Via
Messages postés
7
Date d'inscription
mardi 15 septembre 2020
Statut
Membre
Dernière intervention
16 septembre 2020

Ça marche pas si A1 est négatif ... comment rajouter cette possibilité ?
Messages postés
12651
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
17 septembre 2020
2 008
Que veux tu dire ça ne marche pas ?
Dans tous les cas cela retire 300 comme tu demandais
Si A1=400 400-300 donne 100
si A1 = -400 -400 -300 donne -700
Si dans ce cas cela devrait donner 100 c'est ajouter 300, ta question aurait alors été mal formulée
formule alors : =SI(ET(A1>-300;A1<300);0;SI(A1>0;A1-300;A1+300)
Messages postés
7
Date d'inscription
mardi 15 septembre 2020
Statut
Membre
Dernière intervention
16 septembre 2020

Vous êtes trop Fort
Ça fait 2 jours que je me bats pour trouver une formule qui fonctionne.. mil merci..
Et excusez moi en effet je me suis très mal exprimée mais je ne voyais plus très clair la situation....
J'ai un autre défi pour vous si vous voulez bien.....
Messages postés
12651
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
17 septembre 2020
2 008
Dis moi ....
Messages postés
7
Date d'inscription
mardi 15 septembre 2020
Statut
Membre
Dernière intervention
16 septembre 2020

Maintenant que j'ai ce résultat (grâce a toi) je dois le multiplier par X celon une variante
X étant le prix qui varie celon le type de produit
J'espère m'exprimer correctement et clairement
Messages postés
12651
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
17 septembre 2020
2 008
Il serait plus simple d'avoir un exemple de ton fichier
Poste le sur cjoint.com, copie le lien créé et reviens le coller ici
Messages postés
7
Date d'inscription
mardi 15 septembre 2020
Statut
Membre
Dernière intervention
16 septembre 2020

Je peux pas ce sont des donner confidentiel
Mais pour simplifier
Je dois multiplier ✖ par le prix mais le prix dépend du type de voiture que c'est... donc la variante prix est énorme et différente si la voiture est x ou y ou z....
Messages postés
12651
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
17 septembre 2020
2 008
Si tu as un tarif tu établis d'abord un tableau en 2 colonne de ce tarif sur une autre feuille, en 1ere colonne le type, en 2eme colonne le multiplicateur
Tu sélectionnes tout ton tableau puis clic droit Nommer une plage et tu le nommes par ex tarif
Tu fais RECHERCHEV pour récupérer le multiplicateur en fonction du type
=RECHERCHEV(cellule du type;tarif;2;0) * (cellule du résultat à multiplier)

Si tu n'y arrives pas construit une petit fichier exemple sur le modèle de ton fichier réel avec des données bidons, quelques lignes suffisent et poste le comme demandé plus haut
Messages postés
7
Date d'inscription
mardi 15 septembre 2020
Statut
Membre
Dernière intervention
16 septembre 2020

Je vais essayer et je vous dit... mais c'est du balaise
Vraiment merci de vos réponses
Vs me sauvez la vie
Messages postés
7
Date d'inscription
mardi 15 septembre 2020
Statut
Membre
Dernière intervention
16 septembre 2020

https://www.cjoint.com/c/JIqmCNtZuR7
La formule ne marche pas je ne dois pas faire comme il se doit...
Messages postés
12651
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
17 septembre 2020
2 008
Messages postés
7
Date d'inscription
mardi 15 septembre 2020
Statut
Membre
Dernière intervention
16 septembre 2020

Il y a des endroits où sa fonction pas mais c'est de ma faute
Merci a vous de votre aide qui a été très très précieuse
MERCI