Calculer le temps de discussion

Signaler
-
Messages postés
23377
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
5 juillet 2020
-
Bonjour,

J'ai un document excel, avec dans la colonne A des numéros de téléphone et dans la colonne B le temps de discussion pour un appel (au format hh:mm:ss, ie. 00:02:17 pour 2m17s)

Dans la colonne A, le même numéro de téléphone peut revenir plusieurs fois. J'ai besoin de savoir, pour chaque numéro de cette colonne, le temps de discussion total. J'ai déjà ma liste unique de numéros, mais je ne vois pas comment calculer le temps total pour chaque.

Une piste svp ?

5 réponses

Messages postés
17137
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
7 juillet 2020
4 121
Bonjour,

plusieurs possibilité, exemple le numéro cible en D2, les numéros de tel entre A2 et A10 et le temps colonne B

=SOMMEPROD((A2:A10=D2)*(B2:B10))

Je ne connaissais pas le SOMMEPROD, merci ! Je débute encore, désolé :)
Messages postés
624
Date d'inscription
samedi 2 février 2019
Statut
Membre
Dernière intervention
7 juillet 2020
56
Bonjour,

=SOMMEPROD((A2:A200=A2)*B2:B200)

l'idéal serait d'avoir un menu déroulant (par exemple en C2) avec tous tes n° en A et ensuite :

=SOMMEPROD((A2:A200=$C$2)*B2:B200)

là où est la formule, pense à modifier le format de cellule ;)
Messages postés
624
Date d'inscription
samedi 2 février 2019
Statut
Membre
Dernière intervention
7 juillet 2020
56
Je suis arrivé un poil en retard ^^
Messages postés
17137
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
7 juillet 2020
4 121
Re,

sur les mêmes bases tu peux également utiliser cette formule moins gourmande en ressource

=SOMME.SI(A2:A10;D2;B2:B10)
Messages postés
23377
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
5 juillet 2020
6 224
Bonjour,

les TCD sont prévus pour ce type de synthèse. 0 formule...
Tableau Croisé Dynamique (TCD) : http://www.mdf-xlpages.com/modules/smartsection/item.php?itemid=109
eric