Besoin d'un coup de pouce!

Signaler
-
Messages postés
12367
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
6 juillet 2020
-
Bonjour,

Je cherche une formule qui me permettra de répondre à la demande suivant :
le nombre de tâches attribuées au lot 2 ayant été identifé au mois de XX.
J'ai une formule qui est la suivante : NB.SI.ENS(Plage correspondante; le chiffre du mois en question; Plage correspondante; numéro du lot). Elle fonctionne très bien. Sauf que certaines de mes tâches sont attribuées à plusieurs lots et donc dans la cellule "Lot" il y a plusieurs chiffres indiqués "1; 2; 4" par exemple ou "2; 5; 7". Et dans ce cas ma formule ne prend pas les cellules qui contiennent d'autres chiffres que le chiffre 2. J'ai tenté d'écrire sous différente forme mes chiffres, avec un simple espace, avec un tiret, etc. mais ça ne fonctionne pas.
Auriez-vous une solution pour moi?
J'espère avoir été suffisamment été claire.
Merci d'avance pour votre aide.

Laurianne



Configuration: Windows / Chrome 83.0.4103.106

5 réponses

Messages postés
618
Date d'inscription
samedi 2 février 2019
Statut
Membre
Dernière intervention
6 juillet 2020
56
Bonsoir,

il faudrait partager votre fichier car là nous n'avons pas la structure de celui-ci.

Pour le faire, c'est ici :

https://www.cjoint.com/
Messages postés
12367
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
6 juillet 2020
1 918
Bonjour Laurianne

Il y a surement une solution qu’on pourra trouver facilement si tu tu nous joins ton fichier en le postant sur cjoint.com, en copiant le lien créé et en revenant le coller ici

Cdlmnt
Via
Messages postés
29101
Date d'inscription
mercredi 2 mai 2007
Statut
Modérateur
Dernière intervention
7 juillet 2020
6 484
Bonjour,

On peut utiliser
=NB.SI.ENS(A1:A12;"*2*") 
, mais alors les champs qui ne contiennent que 2, numériques, ne sont pas pris en compte. Quand il y a seulement 2, il faudrait le saisir
'2
, le champ devient alors du texte ou
2;
.

Mais
22;33
sera aussi pris en compte, les n° de lot devraient être encadrés pour bien identifier
;2;22;33;
ainsi on peut rechercher =NB.SI.ENS(A1:A12;";2;") .

Voici le lien vers le fichier excel: https://www.cjoint.com/c/JFtqZ4DurmA

Merci à vous

Laurianne
Messages postés
12367
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
6 juillet 2020
1 918
Re

Essaie en D4 :!
=NB.SI.ENS('Listes des tâches'!$K$5:$K$2496;COLONNE()-3;'Listes des tâches'!$E$5:$E$2496;"*"&$B3&"*")
à étirer vers la droite

Cdlmnt
Via