Formule pour calculer un prix en fonction de la commande [Résolu]

Signaler
-
Messages postés
9571
Date d'inscription
lundi 18 octobre 2010
Statut
Membre
Dernière intervention
27 septembre 2020
-
Bonjour,

Je n'arrive absolument pas à trouver comment faire mon tableau.

Voici la typologie de mon tableau :
J'ai la 1ère ligne avec l'ensemble de mes produits qui donne une colonne par produit.
J'ai la 1ère colonne avec le nom de mes clients qui représente chacun une ligne

lorsque la personne me commande un produit, dans la ligne qui lui ai attribué et dans la colonne du produit commandé, j'y mets la quantité.

En bout de chaque ligne (donc chaque client) j'ai une cellule prix total mais je suis obligée de faire le calcul pour chaque client individuellement. Je souhaiterais donc avoir une formule ou autre pour que les cellules de mes colonnes "produits" aient une valeur correspondant au prix unitaire de mon produit. Lorsque j'inscris 2 je voudrais que le calcul de la somme total se fasse
toute seule en bout de ligne....

J'espere que mes explications ne sont pas trop confuses ??? Merci beaucoup de votre aide.

Configuration: Windows / Firefox 77.0

5 réponses

Messages postés
9571
Date d'inscription
lundi 18 octobre 2010
Statut
Membre
Dernière intervention
27 septembre 2020
1 903
Bonjour

Envoies un bout de ton fichier sur https://mon-partage.fr et joins le lien obtenu à ton prochain message. Ajoutes y un exemple de résultat attendu

Cdlmnt
Messages postés
9571
Date d'inscription
lundi 18 octobre 2010
Statut
Membre
Dernière intervention
27 septembre 2020
1 903
Tu pourrais envisager quelque chose comme ça
https://mon-partage.fr/f/r18R43ZW/

Cdlmnt
Ouiiii !!! super !! Donc une seconde ligne avec le prix.
Pour avoir cette formule partout, je fais comment ??? copier / collage spéciale ??? Juste la formule ?
Messages postés
2101
Date d'inscription
vendredi 25 juillet 2014
Statut
Membre
Dernière intervention
25 septembre 2020
826
Bonsoir
en ajoutant une ligne uniquement avec les prix au kg

en I3
=SOMMEPROD(B3:H3*$B$2:$H$2)
recopier vers le bas
Parfait !! Ça fonctionne !!! Génial !!!! Vous imaginez pas le temps de gagné. MMMMMMMeeeerrrrrrrrrrrccccciiiiiii !!!
Belle soirée à vous !
Merci de cette réponse ultra rapide. Voici un exemple de mon tableau. Je souhaite un calcul auto par ligne client de leur commande . ( exemple 1 pain de campagne à 5€ + 1 pain épeautre à 2.30€)
Je reste à votre dispo pour plus d'explications.
Encore merci de votre aide

Voici le lien du fichier excel d'exemple :
https://mon-partage.fr/f/DFyUjefo/
Messages postés
9571
Date d'inscription
lundi 18 octobre 2010
Statut
Membre
Dernière intervention
27 septembre 2020
1 903