Problème d'affichage de certains éléments uniquement sur Iphone [Résolu]

Signaler
-
 Utilisateur anonyme -
Bonjour à tous,

J'ai créé un site internet et dans la page contact il y a un élément qui ne s'affiche pas. J'ai regardé sur d'autres téléphones s'il y avait le même problème mais apparemment ca ne vient que des iPhones avec safari. le chrome sur iphone affiche tout correctement. Quand j'ouvre l'inspecter sur l'ordi, tout s'affiche normalement aussi. Il n'y a aucune anomalies mais quand je vais le site avec un iphone, le bug apparait.
Alors j'ai vu que quand je sélectionnais l'élément manquant, il y était bien mais il est invisible. J'ai essayé dans le css de modifier les couleurs ou les propriétés mais rien ne change.
Qqun saurait peut etre le vrai pb?
merci pour vos réponses!

3 réponses


Bonjour,
On n'a pas l'adresse du site, pas le nom du thème, ni le plugin utilisait, version de php inconnue, version de WordPress aussi, comment on peut répondre à une question ?
Il y a un élément qui ne s'affiche pas, oui, lequel ??
Merci
Bonjour, le site le voici https://ambrehp.fr
Si vous êtes sur iphone avec safari, dans la page contact au niveau des coordonnées, vous verrez que le numéro ne s'affiche pas mais si vous cliquez dessus vous pourrez le voir s'afficher.
j'ai fait ce site avec divi, quand je l'ai mi en ligne tout paraissait bien mais quelques jours après, le problème est venu et ça juste sur les iphones. Toutes les MAJ sont faites que ce soit de wordpress, divi ou même celle de l'iphone.
De plus, je me suis rendue compte que lorsque je partageais le site par exemple sur les réseaux et que je l'ouvrais à partir de la discussion, tout était nickel, le numéro apparaissait, bizarrement mais dès que on l'ouvre depuis safari le bug etait toujours là
Utilisateur anonyme
Bonjour,
En page d'accueil, au niveau du code source, il y a un code bizarre http://https ??
<span class="et_pb_image_wrap "><img src="http://https://ambrehp.fr/wp-content/uploads/2020/01/calligraphy_brushes_17.png" alt="" title="" srcset="https://ambrehp.fr/wp-content/uploads/2020/01/calligraphy_brushes_17.png 1440w, https://ambrehp.fr/wp-content/uploads/2020/01/calligraphy_brushes_17-300x41.png 300w, https://ambrehp.fr/wp-content/uploads/2020/01/calligraphy_brushes_17-1024x141.png 1024w, https://ambrehp.fr/wp-content/uploads/2020/01/calligraphy_brushes_17-768x106.png 768w, https://ambrehp.fr/wp-content/uploads/2020/01/calligraphy_brushes_17-1080x149.png 1080w, https://ambrehp.fr/wp-content/uploads/2020/01/calligraphy_brushes_17-1280x176.png 1280w, https://ambrehp.fr/wp-content/uploads/2020/01/calligraphy_brushes_17-980x135.png 980w, https://ambrehp.fr/wp-content/uploads/2020/01/calligraphy_brushes_17-480x66.png 480w" sizes="(max-width: 1440px) 100vw, 1440px" /></span>


Vous utilisez le thème Divi version 4.0.5, on voit la version dans le fichier style.css du thème.
La dernière version de ce thème est 4.4.2, c'est indiqué sur la page Changelog.
https://divinotes.com/divi-changelog/

Il faut déjà faire la mise à jour du thème
https://www.elegantthemes.com/documentation/divi/update-divi/
Utilisateur anonyme
Il semble avoir des problème avec le thème Divi et Iphone

https://la-webeuse.com/probleme-de-responsive-avec-le-theme-wordpress-divi/

https://divi.help/threads/several-problems-on-iphone.1834/

Là, il parle que la couleur de numéro de téléphone changent et les modifient en liens, seulement sur Ios
https://css-tricks.com/forums/topic/phone-numbers-not-displaying-in-safari/
Il faut ajouter ce code au CSS
a[href^=tel] {
color: inherit;
text-decoration: none;
}
> Utilisateur anonyme
ah d'accord parfait merci pour votre aide alors, je vais voir tout ça
Utilisateur anonyme > ambre
Merci de nous tenir au courant.
Si vous me le permet, n'oubliez pas d'avoir la page Mentions Légales, est obligatoire, même pour les non-professionnels.
Puis le bandeau de cookies aussi.
en rentrant le code que vous m'avez donné tout fonctionne correctement. merci beaucoup !
Utilisateur anonyme
Superbe, problème résolu.
Merci de mettre le sujet en résolu.