Excel - Liste déroulante conditionnelle [Résolu]

Signaler
-
 MagicSian -
Bonsoir,

Je voudrais arriver à créer sous Excel une liste déroulante dont le contenu affiché serait fonction de la valeur de la cellule d'avant.

Plus precisement, j'ai une liste deroulante "Description" avec des noms de produits. Je souhaiterais dans la cellule suivante qu'apparaisse la référence correspondent au produit sélectionné.

En gros, j'ai sur une feuille Excel (feuille A) le tableau suivant :
| Ref | Description

1 | 0001 | Sacs
2 | 0002 | Pantalons

Dans une autre feuille (feuille B) les cellules suivantes :

Produits | Ref

Une fois le produit sélectionné dans cette feuille, je souhaiterais que la Ref correspondante s'affiche en fonction du choix effectué (si je sélectionne Sacs, je voudrais que 0001 s'affiche automatiquement)

J'espère avoir pu expliquer au mieux mon problème en espérant que quelqu'un pourra me venir en aide :(

Un grand merci d'avance à celui ou celle qui m'aidera à résoudre cette manip qui théoriquement parait tellement simple...

Cordialement.

4 réponses

Bonsoir,
Vous pourriez voir cette autre possibilité :
https://cjoint.com/c/JAqsVAaS0pm
Cordialement
Messages postés
12707
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
27 septembre 2020
2 026
Bonjour magicsiam

Il faut utiliser la combinaison INDEX EQUIV, exemple : https://mon-partage.fr/f/XrdCUSnU/

Cdlmnt
Via
Messages postés
52338
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
27 septembre 2020
14 146
Bonjour.

Tu as donc le choix ...
et si tu optes pour la méthode d'eugène, tu peux aller plus loin en définissant le nom "ref" pour la plage ='FEUILLE A'!$C$5:$D$14 et en écrivant en C7 la formule =RECHERCHEV(D7;ref;2;0)
Bonjour,

Un grand merci à tous pour votre aide et votre réactivité ! C'est parfait.


Vive le forum CCM!

Cdlt