Effacer le contenue d'une cellule avec liste déroulante

[Fermé]
Signaler
-
 lebutters -
Bonjour,

J'utilise depuis peu Excel et je bloque sur un problème dont je ne trouve pas la solution sur les Forums:


J'ai en A48 la formule =SI(A47="Explorations déjà réalisées";"L'enfant a-til déjà eu :";"")
en G50 une liste déroulante avec 3 possibilités : ""; "oui", "non"

Lorsque que "oui" ou "non" a été sélectionné en G50,

Je voudrait que si la condition de A48 est fausse (donc A48="") alors que le contenu de G50 soit effacé sans avoir a le faire manuellement.

J'imagine qu'il faut faire une macro mais je n'y parviens pas

Merci pour votre aide

5 réponses

Messages postés
2470
Date d'inscription
lundi 2 juillet 2018
Statut
Membre
Dernière intervention
20 octobre 2021
443
Bonjour

Un exemple de ton fichier serait le bienvenu
Pour transmettre un fichier, il faut passer par un site de pièce jointe tel que cjoint.com

Va sur ce site : https://www.cjoint.com/
Clic sur parcourir,
Cherche ton fichier,
clic sur ouvrir,
Clic sur "Créer le lien cjoint",
Copier le lien,
Revenir ici le coller dans une réponse..
Cordialement
Voila l'exemple

https://www.cjoint.com/c/IAslmSZW66I

A48 --> A3
G50 --> D4

cordialement
Messages postés
2470
Date d'inscription
lundi 2 juillet 2018
Statut
Membre
Dernière intervention
20 octobre 2021
443
Re Bonjour

Un exemple en VBA

selon que tu affiches oui ou non la colonne G se masque
Tu adaptes le code à ton fichier
En cas de souci n'hésites pas

https://www.cjoint.com/c/IAsn7xqijTk
Cordialement
Merci pour cette réponse,

Je prend note du code (ça peut servir) mais la cellule que je veux faire disparaitre sur le fichier en exemple c'est celle en D4 lorsque A3 devient "" (avec un clearcontents par exemple mais je ne trouve pas le bon code).

Cordialement
Messages postés
2470
Date d'inscription
lundi 2 juillet 2018
Statut
Membre
Dernière intervention
20 octobre 2021
443
regarde cela
J'avais zappé la D4

https://www.cjoint.com/c/IAsqbOD7PFk
Crdlt
Merci pour ton aide c'est parfait!
Une autre question si je peux me permettre :
Si A2 devient =SI(OU(A1="oui";B1="oui");"Explorations déjà réalisées";"") comment je fais pour supprimer complètement le contenu de D4 (uniquement D4) quand A2 = ""?