Formule en SI [Résolu]

Signaler
Messages postés
66
Date d'inscription
mardi 22 août 2017
Statut
Membre
Dernière intervention
21 janvier 2020
-
Messages postés
66
Date d'inscription
mardi 22 août 2017
Statut
Membre
Dernière intervention
21 janvier 2020
-
Bonjour, je ne trouve pas mon erreur... si vous pouvez regarder,
si la somme de D22 est comprise entre 0 et 10064. alors d22*C24. sinon0

somme à chercher : D22


colonne A colonne B Col C
- 0 à 10 064,00 0% =SI($D$22>=A24<=B24;$D$22*C24;0)
10 064,01 à 25 659,00 11% =SI($D$22>=A25<=B25;$D$22*C25;0)
25 659,01 à 73 369,00 30% =SI($D$22>=A26<=B26;$D$22*C26;0)
73 369,01 à 157 806,00 41%
+ 157 806,01 €  45%

Merci.

3 réponses

Messages postés
2060
Date d'inscription
lundi 2 juillet 2018
Statut
Membre
Dernière intervention
24 septembre 2020
341
Bonjour,
Un exemple de votre fichier avec explications serait le bienvenu.
Pour transmettre un fichier,
Veillez à ce qu'il n'y ait PAS DE DONNEES CONFIDENTIELLES
il faut passer par un site de pièce jointe tel que cjoint.com

Allez sur ce site : https://www.cjoint.com/
Clic sur parcourir,
Cherche ton fichier,
clic sur ouvrir,
Clic sur "Créer le lien cjoint",
Copier le lien,
Revenir ici le coller dans une réponse...
Cordialement
Messages postés
2454
Date d'inscription
jeudi 2 juillet 2015
Statut
Membre
Dernière intervention
24 septembre 2020
1 234
Bonjour,

Cette écriture n'est pas possible :
=SI($D$22>=A24<=B24;$D$22*C24;0)

Excel ne comprend pas votre condition.

De plus, votre inéquation n'est pas correcte. Vous avez écris que A24 soit plus petit que D22 et B24.

Je pense que vous vouliez cette inéquation:
$D$22<=A24<=B24

Dans laquelle A24 est entre B24 et D22.

Mais Excel ne comprend pas.
Vous devez plutot écrire dans ce sens:
=Si(D22<= A24 ; Si(A24<= B24;Vrai;Faux);Faux)

Mais comme le conseil JCB40 le mieux sera d'envoyer un fichier pour une meilleure aide
Messages postés
66
Date d'inscription
mardi 22 août 2017
Statut
Membre
Dernière intervention
21 janvier 2020

super, vous avez bien compris.

Merci beaucoup.
Messages postés
2060
Date d'inscription
lundi 2 juillet 2018
Statut
Membre
Dernière intervention
24 septembre 2020
341