Problème avec les sous-formulaires

Signaler
Messages postés
2
Date d'inscription
mercredi 4 septembre 2019
Statut
Membre
Dernière intervention
15 septembre 2019
-
 sylvie041973 -
Je suis débutante en Access 2016 mais j'ai réussi à créer une table et un formulaire avec insertion d'une image.
Mon problème concerne le sous-formulaire que j'ai besoin d'intégrer dans mon formulaire. J'ai créé la table avec les champs que je souhaite voir apparaître dans mon sous formulaire. J'ai intégré ce sous-formulaire dans mon formulaire.
Mais quand je commence à remplir les données dans le sous formulaire de mon premier enregistrement, les mêmes données se reportent dans les enregistrements suivants. Or, les données que je souhaite entrer sont différentes pour chaque enregistrement.
2e problème: je souhaite insérer dans mon sous-formulaire des images. Le lien est présent (trombone pièce jointe) mais l'image ne s'affiche pas.
Je joins un exemple de formulaire pour que ce soit plus clair.


Merci d'avance!

Bonne journée

11 réponses

bonjour
pour avoir un formulaire et un sous formulaire il faut 2 tables reliées entre elles un a 1 l'autre à plusieurs..
https://www.cjoint.com/c/IIeoj7hQAb7
bonjour
dans ce lien un exemple ta base
donne reponse
merci
Bonjour
As tu fais les relations entre les tables?
C'est obligatoire
Bonjour à tous,

J'ai créé les relations entre mes deux tables, et ça fonctionne. Cependant, j'ai toujours un problème d'affichage des images. L'image principale s'affiche bien dans mon formulaire. Mais ce dont j'aurais le plus besoin, c'est que les petites images s'affichent aussi dans mon sous-formulaire. Le lien est présent (trombone) mais il faut double cliquer et faire ajouter pour voir l'image. Y a t'il une solution?

Merci d'avance, cordialement,
bonjour
peux tu mettre ta base compressée sur le site dans un lien avec ci_joint.com

Bonjour,

Voici le lien vers ma base. https://www.cjoint.com/c/IIkhI6Rk30X
Finalement, je me suis aperçue que les relations que j'ai créé ne fonctionnent pas alors que j'ai essayé de faire comme dans votre exemple.
Pour l'affichage des images (stockées sur un disque externe), j'ai vraiment besoin qu'elles s'affichent dans mon sous-formulaire quand il est intégré dans mon formulaire. Je précise que j'aurai besoin d'imprimer chaque enregistrement avec l'image principale du formulaire et les plus petites images du sous-formulaire visibles. Si cela n'est pas possible avec Access, je devrai trouver une autre solution.

Merci pour vos réponses. Cordialement
Messages postés
2
Date d'inscription
mercredi 4 septembre 2019
Statut
Membre
Dernière intervention
15 septembre 2019

Bonjour,
J'ai créé une nouvelle base, cette fois les relations fonctionnent. Mais je ne trouve comment avoir les images visibles (à la place des trombones) dans mes sous-formulaires. J'aimerais avoir ça:


Est-ce possible avec Access? Merci pour vos réponses
Bonjour
As tu defini un champ image dans ta table?
Bonjour
Le champ image tu remplaces piece jointe par un champ olé
bonjour
as tu résolu ton probleme?

Bonjour,
Non je n'ai toujours pas résolu mon problème surtout l'affichage des images dans mes sous formulaire. J'ai "package" à la place de l'image. J'ai lu qu'il valait mieux stocker les images hors de la base et renvoyer vers le chemin de leur emplacement. Mais là c'est du code Vba à entrer dans "procedure evenementielle" et je n'y comprends rien
Bonjour
Tu dois definir ton image avec la proprieté olé. le skocage image est dans un répertoire.
Ensuite, tu ouvres ta table et tu charges ton image.
Il n'y a pas de code vba a faire

Bonjour, j'ai tout essayé. Je n'arrive vraiment pas à avoir l'affichage des images dans mes sous formulaires