Recherche de dizaines manquantes [Fermé]

Signaler
-
 jack -
Bonjour, a tous
dans un tableau excel je voudrais sur une ligne savoir si il manque une dizaine
par exemple 17;25;27;35;45 sur ces 5 cellules il me manque la série 0-9 je ne sais comment on l'appel? quarantaine, trentaine, vingtaine, dizaine, zérotaine? il suffit que je le signale par un o ou x ; mes cellules sont toujours au nombre de 5 et les nombres de 1 à 49
merci pour vos réponses



Configuration: Windows / Edge 17.17134

6 réponses

Messages postés
12798
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
30 octobre 2020
2 050
Bonjour

Avec les 5 nombres en B2:F2 :
=SI(NB.SI(B2:F2;"<10")=0;"x";SI(NB.SI.ENS(B2:F2;">=10";B2:F2;"<20")=0;"x";SI(NB.SI.ENS(B2:F2;">20";B2:F2;"<30")=0;"x";SI(NB.SI.ENS(B2:F2;">=30";B2:F2;"<40")=0;"x";SI(NB.SI(B2:F2;">=40")=0;"x";"")))))

Cdlmnt
Via
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 60511 internautes nous ont dit merci ce mois-ci

merci de ta reponce mais j'ai un prob
E F G H I J
119 1 19 20 30 48 =SI(NB.SI(E119:I119;"<10")=0;"x";SI(NB.SI.ENS(E119:I119;">=10";E119:I119;"<20")=0;"x";SI(NB.SI.ENS(E119:I119;">20";E119:I119;"<30")=0;"x";SI(NB.SI.ENS(E119:I119;">=30";B2:F2;"<40")=0;"x";SI(NB.SI(E119:I119;">=40")=0;"x";"")))))
j ai des erreurs je t'ai mis mes absices et ordonnées
Messages postés
12798
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
30 octobre 2020
2 050
Pourquoi SOMMEPROD ?
Poste un exemple de ton fichier sur mon-partage.fr, copie le lien créé et reviens le coller ici
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 60511 internautes nous ont dit merci ce mois-ci

il y a un problème sur la vongtaine QUAND JE METS 20 C'EST FAUX 21 C'EST BON,,,partout ailleurs c'est bon ???
se serait super si on pouvait solutionner le 20 cordialement et merci
Messages postés
23601
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
30 octobre 2020
6 430
Bonjour à tous,

autre technique :
=SOMMEPROD((GAUCHE(DROITE("0"&B2:F2;2);1)-{0\1\2\3\4}))=0

si chaque dizaine présente => VRAI
eric
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 60511 internautes nous ont dit merci ce mois-ci

Messages postés
9583
Date d'inscription
lundi 18 octobre 2010
Statut
Membre
Dernière intervention
30 octobre 2020
1 929
Bonjour à tous

A y être, une solution avec macro
https://mon-partage.fr/f/knV79UHv/

Cdlmnt
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 60511 internautes nous ont dit merci ce mois-ci

une erreur il manque 0 a 9
merci pour ta réponse mais j'ai un problème
je te reflète une ligne de mes calcul s ainsi que la formule
ai je une erreur? ca ne marche pas
E F G H I J
119 8 19 42 44 48 =SOMMEPROD(((F119:J119)-E119:I119)>10)*E119:J119)
E F G H I J sont mes colonnes
119 est mon numéro de ligne
J est ma cellule de calcul
merci pour ton retour