Formule plus grand que avec si [Résolu]

Signaler
-
 klemasson -
Bonjour,

J'ai un souci avec une formule Excel.
Je souhaiterai que la cellule D4, il reprenne les chiffres des cellules E2 à H2 avec le conditions suivantes :

=SI(D2>E2;"X";SI(D2>F2;"X";SI(D2>G2;"X";SI(D2>H2;"X";""))))

Mais ça ne fonctionne pas et je ne comprends pas ou j'ai fais une erreur.

Pouvez-vous m'aider?

Merci d'avanc e

Configuration: Windows / Chrome 68.0.3440.106

4 réponses

Messages postés
2213
Date d'inscription
jeudi 2 juillet 2015
Statut
Membre
Dernière intervention
3 juillet 2020
1 099
Bonjour,

Qu'elle est le but de votre formule au final... elle doit affiché quoi?

De ce que j'en lit... il ecrit X si D2 est supérieur à une valeur de E2 a H2.

Ca a pas l'air d'être ce que vous souhaitez de ce que je lit de votre paragraphe
Bonjour,

Si c'est exactement ce que je souhaiterai obtenir qu'un X s'affiche s'il D2 est supérieur à la cellule E2/F2/H2/G2.

Ensuite j'aimerai appliqué cette formule sur la cellule E4 mais cette fois avec la E2 en base et qu'un X s'affiche si E2 est supérieur à D2/F2/H2/G2.

Je ne sais pas si c'est tout clair ce que je explique :)

Merci pour votre réponse
Messages postés
2213
Date d'inscription
jeudi 2 juillet 2015
Statut
Membre
Dernière intervention
3 juillet 2020
1 099
Quand vous dites, à la cellule... c'est une Ou TOUTES? Ça a une légère importance sur la formule qui peut sortir:)
Sur une seule cellule :)
Messages postés
25160
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
4 juillet 2020
5 344
Bonjour (et salut diablo)
de ce que j'ai compris
1°) votre formule devrait fonctionner, vérifiez que vos valeurs soient bien numériques
2°) pour faire plus court:
=SI(D2>MAX(E2:H2);"X";"")
crdlmnt
Messages postés
2213
Date d'inscription
jeudi 2 juillet 2015
Statut
Membre
Dernière intervention
3 juillet 2020
1 099
Salut Vaucluse :)

J'ai l'impression que c'est ça :) la recherche du nombre Max :)

Pour plus de souplesse dans la formule ce sera pas mieux :
=SI(D2=MAX(D2:H2);"X";"")

? Ça permettrait de juste modifier une case au lieu de la plage entière
Bonjour,

Ca marche parfaitement !
Merci infiniment !

Encore une petite question :

Comment puis-je faire lorsqu'il y a une égalité par exemple dans la cellule E2 et H2 il y a le même nombre pour lui dire qu'il faut mettre le "X" uniquement dans la plus "petite cellule" donc la E2?

Merci d'avance
Messages postés
25160
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
4 juillet 2020
5 344
je ne comprend pas... vous la mettez où cette formule puisqu'en E2:H2 il y a des valeurs numériques?
si c'est pour tirer de D4 à H4 essayez avec :
=SI(NB.SI($D$2:D2;D2)>1;"";SI(D2=MAX($E$2:$H$2);"X";""))
à tirer de D4 à H4 pour placer le X en face de la première valeur maxi
et si ce n'est pas ce que vous attendez, précisez!
crdlmnt
C'est exactement ça !
Merci beaucoup à tous pour les coups de mains !

Excellente journée à tous
Messages postés
2664
Date d'inscription
dimanche 3 mai 2009
Statut
Membre
Dernière intervention
30 juin 2020
677
Bonjour,

J'ai un doute sur la compréhension de la question,
Si D2 doit être supérieur aux 4 cellules

=SI(ET(D2>E2;D2>F2;D2>G2;D2>H2);"X";"")

Si D2 doit être supérieur à l'une des 4 cellules remplacer ET par OU

Cordialement
Bonjour,

Ca marche également parfaitement !
Merci infiniment !

Je me permets de repose une petite question :

Comment puis-je faire lorsqu'il y a une égalité par exemple dans la cellule E2 et H2 il y a le même nombre pour lui dire qu'il faut mettre le "X" uniquement dans la plus "petite cellule" donc la E2?

Merci d'avance