Erreur avec un package

Résolu
bonjour , j'ai essayer d'installer un package pour le clustering , comme ça juste pour voir...
souci , ça a planté, et maintenant a chaque mise à jour (sudo apt-get upgrade) j'ai
Paramétrage de clvm (2.02.06-2ubuntu9) ...
Starting Cluster LVM Daemon clvmd could not connect to cluster manager
Consult syslog for more information
invoke-rc.d: initscript clvm, action "start" failed.
dpkg : erreur de traitement de clvm (--configure) :
 le sous-processus post-installation script a retourné une erreur de sortie d'état 3
Des erreurs ont été rencontrées pendant l'exécution :
 clvm
E: Sub-process /usr/bin/dpkg returned an error code (1)


j'ai essayé de le desinstaller avec sudo apt-get remove clvm mais sans succés...
une idée???
Configuration: Linux
Firefox 2.0.0.6

13 réponses

  1. Modérateur
    Salut,
    sudo -s
    cd  cd /var/lib/dpkg/info
    for i in list postinst postrm prerm;do mv -v clvm.$i clvm.$i.orig;done
    aptitude purge clvm
    --
    lami20j
    1. Contributeur
      salut,

      pour supprimer tape:
      apt-get remove --purge clvm

      si non essaie:
      apt-get -f install
      1. merci de ta réponse
        j'avais déjà essayé ces commandes
        voila ce que me retourne la première
        $ sudo apt-get remove --purge clvm
        Password:
        Lecture des listes de paquets... Fait
        Construction de l'arbre des dépendances
        Lecture de l'information d'état... Fait
        Les paquets suivants seront ENLEVÉS :
          clvm*
        0 mis à jour, 0 nouvellement installés, 1 à enlever et 8 non mis à jour.
        1 partiellement installés ou enlevés.
        Il est nécessaire de prendre 0o dans les archives.
        Après dépaquetage, 492ko d'espace disque seront libérés.
        Souhaitez-vous continuer [O/n] ?
        (Lecture de la base de données... 137990 fichiers et répertoires déjà installés.)
        Suppression de clvm ...
        Stopping Cluster LVM Daemon invoke-rc.d: initscript clvm, action "stop" failed.
        dpkg : erreur de traitement de clvm (--purge) :
         le sous-processus pre-removal script a retourné une erreur de sortie d'état 1
        Starting Cluster LVM Daemon clvmd could not connect to cluster manager
        Consult syslog for more information
        invoke-rc.d: initscript clvm, action "start" failed.
        dpkg : erreur lors du nettoyage :
         le sous-processus post-installation script a retourné une erreur de sortie d'état 3
        Des erreurs ont été rencontrées pendant l'exécution :
         clvm
        E: Sub-process /usr/bin/dpkg returned an error code (1)
        


        et la seconde
        $ sudo apt-get install -f
        Lecture des listes de paquets... Fait
        Construction de l'arbre des dépendances
        Lecture de l'information d'état... Fait
        0 mis à jour, 0 nouvellement installés, 0 à enlever et 8 non mis à jour.
        1 partiellement installés ou enlevés.
        Il est nécessaire de prendre 0o dans les archives.
        Après dépaquetage, 0o d'espace disque supplémentaires seront utilisés.
        Paramétrage de clvm (2.02.06-2ubuntu9) ...
        Starting Cluster LVM Daemon clvmd could not connect to cluster manager
        Consult syslog for more information
        invoke-rc.d: initscript clvm, action "start" failed.
        dpkg : erreur de traitement de clvm (--configure) :
         le sous-processus post-installation script a retourné une erreur de sortie d'état 3
        Des erreurs ont été rencontrées pendant l'exécution :
         clvm
        E: Sub-process /usr/bin/dpkg returned an error code (1)
        


        si quelqu'un a une autre idée
        1. merci lami20j mais ça ne fonctionne pas non plus
          voici le retour :
          $ sudo dpkg -r --force-all clvm
          Password:
          (Lecture de la base de données... 137990 fichiers et répertoires déjà installés.)
          Suppression de clvm ...
          Stopping Cluster LVM Daemon invoke-rc.d: initscript clvm, action "stop" failed.
          dpkg : erreur de traitement de clvm (--remove) :
           le sous-processus pre-removal script a retourné une erreur de sortie d'état 1
          Starting Cluster LVM Daemon clvmd could not connect to cluster manager
          Consult syslog for more information
          invoke-rc.d: initscript clvm, action "start" failed.
          dpkg : erreur lors du nettoyage :
           le sous-processus post-installation script a retourné une erreur de sortie d'état 3
          Des erreurs ont été rencontrées pendant l'exécution :
           clvm
          
          1. voila :
            $ tail -30 /var/log/syslog
            Sep 20 11:55:21 linuxette-QuadSLI clvmd: Can't open cluster manager socket: No such file or directory
            Sep 20 11:55:48 linuxette-QuadSLI ccsd[4842]: Unable to connect to cluster infrastructure after 8250 seconds.
            Sep 20 11:56:18 linuxette-QuadSLI ccsd[4842]: Unable to connect to cluster infrastructure after 8280 seconds.
            Sep 20 11:56:48 linuxette-QuadSLI ccsd[4842]: Unable to connect to cluster infrastructure after 8310 seconds.
            Sep 20 11:57:19 linuxette-QuadSLI ccsd[4842]: Unable to connect to cluster infrastructure after 8340 seconds.
            Sep 20 11:57:49 linuxette-QuadSLI ccsd[4842]: Unable to connect to cluster infrastructure after 8370 seconds.
            Sep 20 11:58:19 linuxette-QuadSLI ccsd[4842]: Unable to connect to cluster infrastructure after 8400 seconds.
            Sep 20 11:58:49 linuxette-QuadSLI ccsd[4842]: Unable to connect to cluster infrastructure after 8430 seconds.
            Sep 20 11:59:19 linuxette-QuadSLI ccsd[4842]: Unable to connect to cluster infrastructure after 8460 seconds.
            Sep 20 11:59:50 linuxette-QuadSLI ccsd[4842]: Unable to connect to cluster infrastructure after 8490 seconds.
            Sep 20 12:00:20 linuxette-QuadSLI ccsd[4842]: Unable to connect to cluster infrastructure after 8520 seconds.
            Sep 20 12:00:50 linuxette-QuadSLI ccsd[4842]: Unable to connect to cluster infrastructure after 8550 seconds.
            Sep 20 12:01:17 linuxette-QuadSLI dhclient: DHCPDISCOVER on eth1 to 255.255.255.255 port 67 interval 8
            Sep 20 12:01:20 linuxette-QuadSLI ccsd[4842]: Unable to connect to cluster infrastructure after 8580 seconds.
            Sep 20 12:01:25 linuxette-QuadSLI dhclient: DHCPDISCOVER on eth1 to 255.255.255.255 port 67 interval 15
            Sep 20 12:01:40 linuxette-QuadSLI dhclient: DHCPDISCOVER on eth1 to 255.255.255.255 port 67 interval 8
            Sep 20 12:01:48 linuxette-QuadSLI dhclient: No DHCPOFFERS received.
            Sep 20 12:01:48 linuxette-QuadSLI dhclient: No working leases in persistent database - sleeping.
            Sep 20 12:01:50 linuxette-QuadSLI ccsd[4842]: Unable to connect to cluster infrastructure after 8610 seconds.
            Sep 20 12:02:21 linuxette-QuadSLI ccsd[4842]: Unable to connect to cluster infrastructure after 8640 seconds.
            Sep 20 12:02:51 linuxette-QuadSLI ccsd[4842]: Unable to connect to cluster infrastructure after 8670 seconds.
            Sep 20 12:03:21 linuxette-QuadSLI ccsd[4842]: Unable to connect to cluster infrastructure after 8700 seconds.
            Sep 20 12:03:51 linuxette-QuadSLI ccsd[4842]: Unable to connect to cluster infrastructure after 8730 seconds.
            Sep 20 12:04:21 linuxette-QuadSLI ccsd[4842]: Unable to connect to cluster infrastructure after 8760 seconds.
            Sep 20 12:04:52 linuxette-QuadSLI ccsd[4842]: Unable to connect to cluster infrastructure after 8790 seconds.
            Sep 20 12:05:22 linuxette-QuadSLI ccsd[4842]: Unable to connect to cluster infrastructure after 8820 seconds.
            Sep 20 12:05:27 linuxette-QuadSLI dhclient: DHCPDISCOVER on eth1 to 255.255.255.255 port 67 interval 4
            Sep 20 12:05:31 linuxette-QuadSLI dhclient: DHCPDISCOVER on eth1 to 255.255.255.255 port 67 interval 4
            Sep 20 12:05:35 linuxette-QuadSLI dhclient: DHCPDISCOVER on eth1 to 255.255.255.255 port 67 interval 10
            Sep 20 12:05:45 linuxette-QuadSLI dhclient: DHCPDISCOVER on eth1 to 255.255.255.255 port 67 interval 13
            


            effectivement y a la premiere ligne qui parle de clvmd, après ce que ça veut dire et comment faire........
            1. Modérateur
              affiche
              ps aux | grep clvm
              grep clvm /var/log/syslog | tail -30
              --
              lami20j
              1. $ ps aux | grep clvm
                gpu-tech  4329  0.0  0.0   2900   772 pts/0    S+   12:18   0:00 grep clvm
                
                $ grep clvm /var/log/syslog | tail -30
                Sep 20 09:52:34 linuxette-QuadSLI clvmd: Can't open cluster manager socket: No such file or directory
                Sep 20 09:53:56 linuxette-QuadSLI clvmd: Can't open cluster manager socket: No such file or directory
                Sep 20 10:42:50 linuxette-QuadSLI clvmd: Can't open cluster manager socket: No such file or directory
                Sep 20 10:43:09 linuxette-QuadSLI clvmd: Can't open cluster manager socket: No such file or directory
                Sep 20 11:55:21 linuxette-QuadSLI clvmd: Can't open cluster manager socket: No such file or directory
                
                1. pas d'idée ?

                  bien que c'est pas trop grave, je n'est qu'un message d'erreur à chaque upgrade et une attente lorsque je fais un shutdown.. mais sans le message c'est mieux quand meme...

                  en tout cas merci
                  1. voila :
                    $ ls -l /var/lib/dpkg/info/clv*
                    -rw-r--r-- 1 root root  35 2007-04-02 20:40 /var/lib/dpkg/info/clvm.conffiles
                    -rw-r--r-- 1 root root 535 2007-08-29 13:41 /var/lib/dpkg/info/clvm.list
                    -rw-r--r-- 1 root root 596 2007-04-02 20:40 /var/lib/dpkg/info/clvm.md5sums
                    -rwxr-xr-x 1 root root 318 2007-04-02 20:40 /var/lib/dpkg/info/clvm.postinst
                    -rwxr-xr-x 1 root root 170 2007-04-02 20:40 /var/lib/dpkg/info/clvm.postrm
                    -rwxr-xr-x 1 root root 281 2007-04-02 20:40 /var/lib/dpkg/info/clvm.prerm
                    -rw-r--r-- 1 root root  29 2007-04-02 20:40 /var/lib/dpkg/info/clvm.shlibs