Fonction =SI(ESTNA(RECHERCHEV(..................... [Résolu/Fermé]

Signaler
Messages postés
11
Date d'inscription
mercredi 13 mars 2019
Statut
Membre
Dernière intervention
25 mars 2019
-
Messages postés
2725
Date d'inscription
dimanche 3 mai 2009
Statut
Membre
Dernière intervention
11 août 2020
-
Bonjour,

j'explique mon problème j'aimerais faire apparaitre dans la colonne A de l'onglet "services" DVC OU NDVC selon le nom ou le matricule du collaborateur peu importe. Tout ca par le biais d'une formule avec SI, ESTNA et RECHERCHEV en allant chercher dans la colonne G de l'onglet "DATA" les fameux DVC ou NDVC... HELP !!

merci par avance la communauté :)

6 réponses

Messages postés
2725
Date d'inscription
dimanche 3 mai 2009
Statut
Membre
Dernière intervention
11 août 2020
702
Bonjour

Ça manque de biscuit ; ma réponse avec ce que j'ai compris

Dans l'onglet "service" il faut une colonne avec le nom ou le matricule ce qui permettra d'aller chercher l'info dans l'onglet DATA ; disons que l'info est en colonne B de l'onglet service

en A2
Pour une recherche avec le nom
=SIERREUR(RECHERCHEV(onglet service!B2;onglet DATA!$A$2:$G$fin du tableau;7;0);"")

Pour une recherche avec le matricule
=SIERREUR(RECHERCHEV(onglet service!B2;onglet DATA!$C$2:$G$fin du tableau;5;0);"")

Cordialement
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 57594 internautes nous ont dit merci ce mois-ci

Messages postés
2725
Date d'inscription
dimanche 3 mai 2009
Statut
Membre
Dernière intervention
11 août 2020
702
Re:
Voilà j'ai corrigé les formules ainsi que l'erreur div/0 de la ligne 7 tableau récap. comme je l'aurai fait pour moi

https://www.cjoint.com/c/ICokgy5Y1qb

Si tu es satisfait ne pas oublier de mettre en résolu en cliquant sur la roue dentée à droite du titre.

Cordialement
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 57594 internautes nous ont dit merci ce mois-ci

Messages postés
11
Date d'inscription
mercredi 13 mars 2019
Statut
Membre
Dernière intervention
25 mars 2019




voici mon onglet ou se trouve la colonne service tout a gauche
Messages postés
11
Date d'inscription
mercredi 13 mars 2019
Statut
Membre
Dernière intervention
25 mars 2019

cela ne fonctionne pas avec votre formule cela me laisse des cases vides. et il possible de vous envoyer mon fichier par mail par exemple ?
Messages postés
2725
Date d'inscription
dimanche 3 mai 2009
Statut
Membre
Dernière intervention
11 août 2020
702
Messages postés
2725
Date d'inscription
dimanche 3 mai 2009
Statut
Membre
Dernière intervention
11 août 2020
702
Bonjour

Pour la zone de recherche sur la feuille data il vaut mieux limiter à la hauteur du tableau pour ne pas ralentir excel

en A14 de la feuille service essayer cette formule

=SIERREUR(RECHERCHEV(D14;DATA!$C$2:$G$100;5;0);"")

Ne pas oublier de fixer la zone de recherche avec $ - remplacer $G$100 par la dernière cellule renseignée de la colonne G

Cordialement
Messages postés
11
Date d'inscription
mercredi 13 mars 2019
Statut
Membre
Dernière intervention
25 mars 2019

https://www.cjoint.com/c/ICohYH24CHp

voici le lien, sachant que mes colonnes A B et C de l'onglet service ont des formules erronées merci de voir ce qui est possible afin de remédier à cela :)
Messages postés
2725
Date d'inscription
dimanche 3 mai 2009
Statut
Membre
Dernière intervention
11 août 2020
702
suis obligé de m'absenter, je regarde ça à mon retour