Mise à jour de php [Fermé]

Signaler
-
 finette35 -
Bonjour
Je souhaiterai mettre à jour php pour mon site wordpress et migrer vers php7.3.
Quelqu’un pourrait il m'indiquer le mode opératoire. Merci d'avance
A voir également:

24 réponses

Tout d'abord Elgazar je veux te remercier pour toute cette aide.
j'ai fait la modification . Maintenant il n'apparait que le nom de la catègorie. C'est bien mais auparavent avant que je fasse la mise à jours du thème, il n'apparaissait rien ..

Bonne journée
Messages postés
5836
Date d'inscription
mercredi 30 octobre 2013
Statut
Membre
Dernière intervention
3 janvier 2021
1 162
dans ce cas, tu peux effacer la ligne complète pour enlever l'espace que prenait le titre ou seulement ce qui en php comme ci-dessous si tu veux garder l'emplacement et son fond de couleur

<?php printf( __( '%s ', 'twentythirteen' ), single_cat_title( '', false ) ); ?>
Merci .
je voulais te montrer le message que j'ai sur le tableau de bord

Mise à jours de PHP
WordPress a détecté que votre site tourne sur un version non sécurisée de PHP.
Qu’est-ce que PHP et comment cela affecte t-il mon site ?

PHP est le langage de programmation que nous utilisons pour bâtir et maintenir WordPress. Les nouvelles versions de PHP sont à la fois plus rapides et plus sécurisées. La mise à jour aura donc un effet positif sur les performances de votre site.
Sur ovh config, j'ai bien PHP7.3
Je vais appeler OVH pour avoir une explication
ou bien il y a t'il du code a modifier quelque part ?
Connais tu une alternative à l'extension mail poet2, cette dernière va être abandonnée.
je viens d'avoir une réponse d'OVH pour le problème du PHP

La version PHP 7.3 que nous déployons sur les hébergements est une version totalement sécurisé. Le message que vous avez provient potentiellement d'un soucis de compatibilité entre votre version de Wordpress et la version 7.3 de PHP. Cela constitue une demande de webmastering, nous n'effectuons cependant un webmastering ni aucune infogérance. Je vous invite à vous rapprocher d'un webmaster qui pourra effectuer les analyses pour vous et voir coté code ce qui pose problème.
A savoir si wordpress version 5 est compatible avec PHP3
Messages postés
5836
Date d'inscription
mercredi 30 octobre 2013
Statut
Membre
Dernière intervention
3 janvier 2021
1 162
wordpress est compatible avec php7.3

est ce que cela ne seraity pas simplement un problème de cache "alakon", essaye en vidant le cache de ton navigateur, si ca marche pas, désactive un par un les plugins et vérifie si tu as toujours le message

J'ai fait ma manip mais cela n'a rien changé.
Y a t'il un moyen de vérifier la version utilisée de PHP ? mais comme je travaille sur la base de données hébergée par OVH et que mon fichier .ovh conf mentionne PHP7.3 cela doit être.
Ce pavé d'avertissement est mis systématiquementpour la version 5.1 et qu'à la prochaine mise à jour cela va disparaître. Sinon le site fonctionne bien.
Mailpoet 2 va être arrêter au printemps 2019, c'est dommage car c'était bien pratique, il va être remplacer par mailpoet 3 à 99€ par an.
Connais tu un plugin pour faire de la messagerie ?

Merci beaucoup et bonne soirée