CALCUL

Résolu/Fermé
CETIFA Messages postés 33 Date d'inscription vendredi 24 avril 2015 Statut Membre Dernière intervention 19 mars 2020 - 2 mars 2019 à 17:13
CETIFA Messages postés 33 Date d'inscription vendredi 24 avril 2015 Statut Membre Dernière intervention 19 mars 2020 - 3 mars 2019 à 09:37
Bonjour à tous,
Dans une feuille de calcul, j'ai une colonne A et une colonne B comme suit :
620 1.00
620 1.00
620 1.00
621 1.00
621 1.00
640 1.00
640 1.00
640 1.00
640 1.00
Je souhaite obtenir une formule qui fasse le total de la colonne B en fonction de la colonne A, à savoir dans le cas présent :
620 3.00
621 2.00
640 4.00
Je vous remercie par avance de vos recherches.
Bonne soirée à tous.
A voir également:

4 réponses

jordane45 Messages postés 38142 Date d'inscription mercredi 22 octobre 2003 Statut Modérateur Dernière intervention 20 avril 2024 4 649
3 mars 2019 à 00:36
2
CETIFA Messages postés 33 Date d'inscription vendredi 24 avril 2015 Statut Membre Dernière intervention 19 mars 2020
3 mars 2019 à 09:12
Apprendre reste un bonheur. D'autant plus que le maitre d'apprentissage vous accompagne comme vous venez de le faire. Merci. Bonne journée.
0
Utilisateur anonyme
2 mars 2019 à 17:39
Bonjour,
Vous pourriez essayer les formules :
=SOMME.SI($A$1:$B$9;620;$B$1:$B$9)
=SOMME.SI($A$1:$B$9;621;$B$1:$B$9)
=SOMME.SI($A$1:$B$9;640;$B$1:$B$9)
Cordialement,
Arthur
0
baladur13 Messages postés 46388 Date d'inscription mercredi 11 avril 2007 Statut Modérateur Dernière intervention 20 avril 2024 13 212
2 mars 2019 à 17:43
Bonjour,
La colonne B contient toujours 1 ?
Si oui la formule nombre si devrait faire le travail
Voir https://support.microsoft.com/fr-fr/office/nb-si-nb-si-fonction-e0de10c6-f885-4e71-abb4-1f464816df34?ui=fr-fr&rs=fr-fr&ad=fr
0
CETIFA Messages postés 33 Date d'inscription vendredi 24 avril 2015 Statut Membre Dernière intervention 19 mars 2020
2 mars 2019 à 18:46
Bien évidement, cela serait trop facile. Sur 3912 lignes, la colonne A contient 349 valeurs différentes, la B 223 !!!
Avez-vous une solution ?
D'avance, merci.
0
Raymond PENTIER Messages postés 58391 Date d'inscription lundi 13 août 2007 Statut Contributeur Dernière intervention 21 avril 2024 17 090
3 mars 2019 à 00:25
Arthur-92 te l'a donnée du premier coup, ta solution ! Tu ne l'as même pas essayée ?

Mais tu peux aussi utiliser DONNÉES / Sous-total ...
0
CETIFA Messages postés 33 Date d'inscription vendredi 24 avril 2015 Statut Membre Dernière intervention 19 mars 2020
3 mars 2019 à 09:37
J'ai bien essayé, mais les 349 valeurs de la colonne A ne se suivent pas numériquement.
Suite à la réponse de Jordane45, j'ai utilisé un tableau croisé dynamique et trouvé ma solution.
Merci de votre aide.
Bonne journée.
0
Utilisateur anonyme
Modifié le 3 mars 2019 à 06:03
Pour un grand nombre de lignes on peut remplacer dans la formule les nombres 620, 621, 640 etc. par une référence de cellule, par exemple en F1, F2, F3 etc., ce qui permet un copier/coller rapide.
0