Réponse selon quelle cellule est remplie [Résolu/Fermé]

Signaler
Messages postés
7
Date d'inscription
jeudi 1 janvier 2015
Statut
Membre
Dernière intervention
21 février 2019
-
Messages postés
51904
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
11 juillet 2020
-
Bonjour,

Je cherche depuis un moment une solution pour réussir à faire ceci.

Si l'une des 3 cellules A1, B1, C1 est pleine alors selon laquelle est pleine, une certaine formule exécutée, une quatrième formule si A1 et C1 sont pleines et pouvoir mettre ces 4 formules dans la même cellule pour avoir la solution des 4 formules possibles en D1

Merci d'avance

2 réponses

Messages postés
2216
Date d'inscription
jeudi 2 juillet 2015
Statut
Membre
Dernière intervention
3 juillet 2020
1 104
Bonjour,

4 Formules?

J'en vois que deux personnellement, dans le cas ou A1 OU B1 OU C1 est rempli, et la formule dans le cas ou A1 ET C1 sont rempli. Je me trompe?
Messages postés
7
Date d'inscription
jeudi 1 janvier 2015
Statut
Membre
Dernière intervention
21 février 2019

Les formules sont différentes selon si c'est A1 ou A2 qui est remplie.
Messages postés
2216
Date d'inscription
jeudi 2 juillet 2015
Statut
Membre
Dernière intervention
3 juillet 2020
1 104
Vous parlez jamais de A2 ...

Pouvez-vous me dire ce que vous voulez Exactement...
Messages postés
7
Date d'inscription
jeudi 1 janvier 2015
Statut
Membre
Dernière intervention
21 février 2019

Excusez moi c'est pas A2 mais B1 =)
Messages postés
51904
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
11 juillet 2020
13 638
Bonjour.

=SI(ET(A1<>"";B1="";C1="");form1;SI(et(A1="";B1<>"";C1="");form2;SI(ET(A1="";B1="";C1<>"");form3;SI(ET(A1<>"";B1="";C1<>"");form4;"incomplet"))))
Messages postés
7
Date d'inscription
jeudi 1 janvier 2015
Statut
Membre
Dernière intervention
21 février 2019

Merci c'est parfaitement ça, ça fonctionne !
Messages postés
51904
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
11 juillet 2020
13 638
Alors repère bien la logique de la formule, afin d'être en mesure de l'adapter aux différents problèmes qui se présenteront.
Cordialement.