Erreur dans C:\WINDOWS\system32\nvspcap64.dll Entrée manquante : ShadowPlayOnSys [Fermé]

Signaler
Messages postés
48
Date d'inscription
vendredi 12 avril 2013
Statut
Membre
Dernière intervention
9 décembre 2018
-
Messages postés
48
Date d'inscription
vendredi 12 avril 2013
Statut
Membre
Dernière intervention
9 décembre 2018
-
Bonjour,

Comme le titre le précise, j'ai GeForce Experience qui me fait une erreur au démarrage Windows :

Erreur dans C:\WINDOWS\system32\nvspcap64.dll
Entrée manquante : ShadowPlayOnSystemStart

Cette erreur ne semble pas gêner l'utilisation de ShadowPlay mais le message d'erreur systématique est agaçant.

J'ai bien évidement désinstallé et réinstallé proprement Geforece Experience, rien à faire.

Quelqu'un aurait une idée ?

Merci d'avance.

8 réponses

Messages postés
80653
Date d'inscription
mercredi 27 mai 2009
Statut
Modérateur
Dernière intervention
12 octobre 2020
11 690
Télécharge et installe --> Revo Uninstaller
Lance-le en tant qu'administrateur
Désinstalle Geforce Experience
Suis bien le tuto pour tout désinstaller proprement incluant les dossiers et clés résiduelles.
Redémarre le pc.

Ne le réinstalle pas pour l'instant.
As-tu encore le message d'erreur ?



Mes salutations Malekal et pistouri.
3
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 60511 internautes nous ont dit merci ce mois-ci

Messages postés
48
Date d'inscription
vendredi 12 avril 2013
Statut
Membre
Dernière intervention
9 décembre 2018

L'erreur a changée :

Problème lors du démarrage de
C:\WINDOWS\system32\nvspcap64.dll
Le module spécifié est introuvable.
Messages postés
48
Date d'inscription
vendredi 12 avril 2013
Statut
Membre
Dernière intervention
9 décembre 2018

Merci, avec l'aide de @pistouri, cette nouvelle erreur de dll est corrigée.
Messages postés
13484
Date d'inscription
dimanche 14 juin 2015
Statut
Contributeur
Dernière intervention
12 octobre 2020
5 671
Bonjour,

Fais une vérification des fichiers systéme:
Dans Cortana tape → cmd
Clique droit sur l'invite de commandeExécuter en Administrateur
Fais un copier/coller:

sfc /scannow

Puis entrée clavier
Regarde à la fin si tu as des erreurs ou si elles ont étaient réparées.

Sinon tape cette commande puis entrée clavier

DISM /Online /Cleanup-Image /RestoreHealth

Ferme la fenêtre une fois terminé et redémarre le PC

Tu peux te servir de ce petit soft sfcfix à la place si tu préfère , il est un peu plus complet que la commande
Malekal le propose ici
Redémarre le PC à la fin .

Vérifies si nvspcap64.dll est présent dans Windows:
-Va dans CE-PC→ disque local (C)→ Windows→System32
Va dans CE-PC→ disque local (C) →Windows→ SysWOW64

Pour info ils sont bien présent dans ces répertoires ayant également une Nvidia.

Si pas présent prends la ici
Replace la ensuite dans les 2 répertoires

Vérifies si tu vois nvspapi64.dll dans ce répertoire
Va dans CE-PC→ disque local (C)→ Programmes Files→NVIDIA Corporation→ShadowPlay
Regarde bien si tu n 'as pas un trait devant le nom → "_NVSPCAP.dll '
Si oui renomme le en supprimant le trait ce qui donne → NVSPCAP.dll
Redémarre le PC.

A+
3
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 60511 internautes nous ont dit merci ce mois-ci

Messages postés
48
Date d'inscription
vendredi 12 avril 2013
Statut
Membre
Dernière intervention
9 décembre 2018

L'erreur a disparu au démarrage oui. J'attendais la confirmation avant de réinstaller.

Merci pour l'aide. Le problème a l'air résolu avec la solution de @kaeneagle pour la désinstallation "propre" de GeaForce Experience et la seconde solution pour la correction du problème de dll.
Messages postés
13484
Date d'inscription
dimanche 14 juin 2015
Statut
Contributeur
Dernière intervention
12 octobre 2020
5 671
Nous sommes contents pour toi.
Conseil: Désactiver la mise à jour automatique des pilotes
Regarde comment faire en suivant le tuto de Malekal

Marque la discussion comme résolue à présent en espérant que le problème ne revienne pas
Bonne fin de journée.
Messages postés
48
Date d'inscription
vendredi 12 avril 2013
Statut
Membre
Dernière intervention
9 décembre 2018

Bon comme je le craignais, à la réinstallation de GeForce Experience, l'erreur initiale a réapparu.
Messages postés
80653
Date d'inscription
mercredi 27 mai 2009
Statut
Modérateur
Dernière intervention
12 octobre 2020
11 690
Si c'est seulement pour la mise à jour du pilote, pourquoi installer ge experience ?
Tu télécharges le dernier pilote
Décompresse-le
Installe-le manuellement via le gestionnaire des périphériques
Sélectionne le dossier Display.Driver.
Regarde le --> message 20
Messages postés
48
Date d'inscription
vendredi 12 avril 2013
Statut
Membre
Dernière intervention
9 décembre 2018

Non je m'en sers pas mal pour ShadowPlay justement et optimiser les jeu rapidement avant de fignoler moi même.

Enfin bon c'est pas très grave, c'est juste un message d'erreur qui n'est pas handicapant. C'est juste frustrant de voir ça à chaque démarrage de windows.

Je règlerais ça avec un bon vieux formatage dans les règles quand j'aurais la motivation.
Messages postés
180117
Date d'inscription
mercredi 17 mai 2006
Statut
Modérateur, Contributeur sécurité
Dernière intervention
4 octobre 2020
22 281
Salut,

Réinstalle proprement les pilotes de la carte graphique : https://www.malekal.com/reinstaller-proprement-pilotes-cartes-graphiques/
Fais un nettoyage DDU.
Messages postés
180117
Date d'inscription
mercredi 17 mai 2006
Statut
Modérateur, Contributeur sécurité
Dernière intervention
4 octobre 2020
22 281 >
Messages postés
48
Date d'inscription
vendredi 12 avril 2013
Statut
Membre
Dernière intervention
9 décembre 2018

Tu dois pouvoir désactiver l'entrée avec Autoruns, voir : https://www.malekal.com/autoruns/

Depuis Everything, Filtre sur ces éléments et décoche l'entrée :
nvspcap64.dll
ShadowPlayOnSystemStart
Messages postés
48
Date d'inscription
vendredi 12 avril 2013
Statut
Membre
Dernière intervention
9 décembre 2018

Je regarde ça dès que j'ai un moment.
Messages postés
48
Date d'inscription
vendredi 12 avril 2013
Statut
Membre
Dernière intervention
9 décembre 2018

Je ne trouve pas les entrées dans Autoruns :
Messages postés
180117
Date d'inscription
mercredi 17 mai 2006
Statut
Modérateur, Contributeur sécurité
Dernière intervention
4 octobre 2020
22 281 >
Messages postés
48
Date d'inscription
vendredi 12 avril 2013
Statut
Membre
Dernière intervention
9 décembre 2018

cherche sur ShadowPlayOnSystemStart ?
Messages postés
48
Date d'inscription
vendredi 12 avril 2013
Statut
Membre
Dernière intervention
9 décembre 2018

Aucun résultat : /
Messages postés
80653
Date d'inscription
mercredi 27 mai 2009
Statut
Modérateur
Dernière intervention
12 octobre 2020
11 690
Bonjour,

Désinstalle Geforce Experience
Redémarre le pc
Vois si le message persiste.

Messages postés
48
Date d'inscription
vendredi 12 avril 2013
Statut
Membre
Dernière intervention
9 décembre 2018

Comme marqué précédemment, déjà fait et aucun changement.
Messages postés
80653
Date d'inscription
mercredi 27 mai 2009
Statut
Modérateur
Dernière intervention
12 octobre 2020
11 690
Tu l'as juste désinstallé, pas réinstallé depuis ?
Messages postés
48
Date d'inscription
vendredi 12 avril 2013
Statut
Membre
Dernière intervention
9 décembre 2018

Bah si :)
Messages postés
13484
Date d'inscription
dimanche 14 juin 2015
Statut
Contributeur
Dernière intervention
12 octobre 2020
5 671
Bonjour,

Si tu as un Windows 10 64 bits
Installe le dernier driver NVIDIA GeForce 417.01 WHQL ici
Sorti le 26 novembre 2018 , donc ce jour ci.
Lien direct ici

Lors de l 'installation tu peux choisir → Personnalisée (avancée) →Effectuer une nouvelle installation




Dis nous si le message apparaît après avoir redémarré le PC.

Je salue kaneagle et Malekal au passage.

A+

Messages postés
48
Date d'inscription
vendredi 12 avril 2013
Statut
Membre
Dernière intervention
9 décembre 2018

Le problème est apparu ça doit faire un bon moi voire peut être plus. J'ai fait maintes tentatives d'installation, avec et sans nouvelle installation et rien n'y fait.
Le problème persiste même sans drivers installés ni GeForce Experience installé, je ne comprend même pas pourquoi windows cheche ce dll alors que le logiciel qui est sensé s'en servir n'est plus installé.

Je vais faire une dernière tentative avec la solution de kaneagle dès que j'ai un moment. mais le formatage pointe le bout de son nez...
Messages postés
80653
Date d'inscription
mercredi 27 mai 2009
Statut
Modérateur
Dernière intervention
12 octobre 2020
11 690
Touche Windows + R
Tape --> devmgmt.msc et OK.

Donne le no. d'identification de matériel de la carte nVidia
Regarde ceci --> Trouver le numéro d'identification d'un périphérique
Poste le no. dans ton prochain message.

C'est quoi la marque et le no. du modèle exact du pc ?

Windows 7, 8 ou 10 est en 32 ou 64 bits ?

Messages postés
48
Date d'inscription
vendredi 12 avril 2013
Statut
Membre
Dernière intervention
9 décembre 2018

PCI\VEN_10DE&DEV_1B80&SUBSYS_33621462&REV_A1

Sinon c'est un PC assemblé moi même

i7 8700K (non OC pour le moment)
MSI Z370 Krait Gaming
16Go DDR4
MSI GeForce GTX 1080 Gaming X 8Go...

Windows 10 Pro 64 bits
Messages postés
80653
Date d'inscription
mercredi 27 mai 2009
Statut
Modérateur
Dernière intervention
12 octobre 2020
11 690
Télécharge et installe --> 7Zip 64 bits

Télécharge ce pilote --> nVidia

Fais clic droit sur --> 417.22-desktop....exe
Sélectionne --> 7Zip
Choisis --> extraire vers "417.22-desktop.....\"

Va dans le gestionnaire de périphériques
Fais clic droit sur le périphérique
Mettre à jour le pilote
Parcourir mon ordinateur ......
Parcourir
Va dans le dossier du pilote dézippé --> 417.22-desktop.....
Sélectionne le dossier --> Display.Driver
OK, suivant
Redémarre.

Messages postés
48
Date d'inscription
vendredi 12 avril 2013
Statut
Membre
Dernière intervention
9 décembre 2018

"Les meilleurs pilotes pour votre périphérique sont déjà installés."

Je les tiens toujours à jour.
Messages postés
180117
Date d'inscription
mercredi 17 mai 2006
Statut
Modérateur, Contributeur sécurité
Dernière intervention
4 octobre 2020
22 281
Chez moi nvspcap64.dll est dans deux emplacements :
  • C:\ProgramData\NVIDIA Corporation\Downloader\PostProcessing\GFE\9b5f9291927a0ab07ce007a29243f05f\ShadowPlay
  • C:\Windows\system32


Tu les as aussi à ces emplacements ?



Quelle taille fait ton fichier nvspcap64.dll ?

Messages postés
180117
Date d'inscription
mercredi 17 mai 2006
Statut
Modérateur, Contributeur sécurité
Dernière intervention
4 octobre 2020
22 281 >
Messages postés
13484
Date d'inscription
dimanche 14 juin 2015
Statut
Contributeur
Dernière intervention
12 octobre 2020

Entrée manquante : ShadowPlayOnSystemStart
il doit pas avoir la bonne version de la DLL.
La fonction ShadowPlayOnSystemStart est manquante dans la sienne.

Faudrait voir la taille de la sienne.
Messages postés
48
Date d'inscription
vendredi 12 avril 2013
Statut
Membre
Dernière intervention
9 décembre 2018

2,73 Mo aussi et je l'ai dans C:\\Windows\SysWOW64 également.
Messages postés
180117
Date d'inscription
mercredi 17 mai 2006
Statut
Modérateur, Contributeur sécurité
Dernière intervention
4 octobre 2020
22 281 >
Messages postés
48
Date d'inscription
vendredi 12 avril 2013
Statut
Membre
Dernière intervention
9 décembre 2018

et dans C:\ProgramData\NVIDIA Corporation\Downloader\PostProcessing\GFE\9b5f9291927a0ab07ce007a29243f05f\ShadowPlay ?
ou un dossier qui s'apparente ?
Messages postés
13484
Date d'inscription
dimanche 14 juin 2015
Statut
Contributeur
Dernière intervention
12 octobre 2020
5 671
Dans ShadowPlay
Messages postés
48
Date d'inscription
vendredi 12 avril 2013
Statut
Membre
Dernière intervention
9 décembre 2018

Pas de dossier Downloader dans NVIDIA Corporation