Compter nb "oui" correspond. à colonne ac doublons [Résolu/Fermé]

Signaler
Messages postés
9
Date d'inscription
samedi 18 août 2018
Statut
Membre
Dernière intervention
20 août 2018
-
Messages postés
9
Date d'inscription
samedi 18 août 2018
Statut
Membre
Dernière intervention
20 août 2018
-
Bonjour,

Je me tourne vers vous, car je recherche une solution depuis un moment de mon côté sans parvenir à trouver la formule. Pourriez-vous m'aider svp ?

Je vous présente la situation de mon tableau et de ma difficulté ci-dessous :

Colonne A : Une liste de code qui contient des doublons et que je vais continuer à alimenter.

Colonne B : Une liste de "oui" et de "non" réalisée à partir d'une liste déroulante.
Cette liste de oui/non fait référence aux codes de la colonne A qui contient des doublons.

Cellule D2 : J'ai calculé le nombre de code que contient la colonne A sans les doublons, avec l'aide de cette formule :
=SOMMEPROD((FREQUENCE(A2:A31;A2:A31)>0)*1)

Cellule E2 : Je souhaiterais calculer le nombre de "oui" qui fait référence aux codes de la colonne A ,mais encore une fois, sans compter les doublons.
J'ai essayé avec NB.SI.ENS mais je n'y parviens pas.
Existe-t-il une formule? Je recherche une solution sans passer par un TCD si possible.

Merci par avance pour votre réponse.

3 réponses

Messages postés
994
Date d'inscription
lundi 23 juillet 2012
Statut
Membre
Dernière intervention
28 mai 2019
149
Bonjour,

Essaie ça :
=SOMMEPROD((FREQUENCE(A2:A31;A2:A31)>0)*(B2:B31="oui"))
Messages postés
9
Date d'inscription
samedi 18 août 2018
Statut
Membre
Dernière intervention
20 août 2018

Bonjour tuxboy,

Merci pour votre réponse.
Je n'obtient pas de résultat avec cette formule mais ceci : #N/B
Messages postés
994
Date d'inscription
lundi 23 juillet 2012
Statut
Membre
Dernière intervention
28 mai 2019
149
en colonne B, tu n'as que des "oui" et des "non" ?
Messages postés
9
Date d'inscription
samedi 18 août 2018
Statut
Membre
Dernière intervention
20 août 2018
>
Messages postés
994
Date d'inscription
lundi 23 juillet 2012
Statut
Membre
Dernière intervention
28 mai 2019

En colonne B, il n'y a que des "oui" des "non" et les cellules suivantes que je n'ai pas encore utilisées qui sont vides
Messages postés
994
Date d'inscription
lundi 23 juillet 2012
Statut
Membre
Dernière intervention
28 mai 2019
149
J'ai une autre idée :
=NB(1/FREQUENCE(SI((B2:B31="oui");EQUIV(A2:A31;A2:A31;0));LIGNE(INDIRECT("1:"&LIGNES(A2:A31)))))

et tu valides cette formule matricielle en appuyant simultanément CTRL-MAJ-ENTREE

;)
Messages postés
9
Date d'inscription
samedi 18 août 2018
Statut
Membre
Dernière intervention
20 août 2018
>
Messages postés
994
Date d'inscription
lundi 23 juillet 2012
Statut
Membre
Dernière intervention
28 mai 2019

Bonjour Tuxboy,

Je souhaitais vous remercier pour votre aide mais enfin de compte j'ai trouvé la solution via la matrice suivante :

= SOMME(SI(Suivi!C2:C31="Oui";1/NB.SI(Suivi!A2:A31;Suivi!A2:A31)))

Encore merci pour votre aide! ;)

Bonne journée à vous.
Messages postés
9
Date d'inscription
samedi 18 août 2018
Statut
Membre
Dernière intervention
20 août 2018

Re bonjour tuxboy,

Merci d'avoir pris le temps de me répondre. La formule ne fonctionne pas non plus .
Messages postés
23421
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
11 août 2020
6 284
Bonjour,

Merci de déposer le fichier xls (réduit au nécessaire et anonymisé, avec le résultat attendu) sur cjoint.com et coller ici le lien fourni.
eric
Messages postés
9
Date d'inscription
samedi 18 août 2018
Statut
Membre
Dernière intervention
20 août 2018

Bonjour Eriiic,

Merci de tenter de m'aider.
Voici-ci le lien du fichier : https://www.cjoint.com/c/HHtlSff1HJq
(anonymisé avec seulement la partie concernée et un tableau synthétique "blabla" qui est en réalité est plus important et sur une autre feuille)

Donc, J'aurais souhaité calculer le nombre de "oui", puis de "non" qui fait référence aux codes de la colonne A ,mais encore une fois, sans compter les doublons. Si possible sans Tcd.

Merci.
Messages postés
9
Date d'inscription
samedi 18 août 2018
Statut
Membre
Dernière intervention
20 août 2018

Bonjour Eriiic et Tuxboy,

Je souhaitais vous remercier pour votre aide mais enfin de compte j'ai trouvé la solution via la matrice suivante :

= SOMME(SI(Suivi!C2:C31="Oui";1/NB.SI(Suivi!A2:A31;Suivi!A2:A31)))

Encore merci pour votre aide! ;)

Bonne journée à vous.
Messages postés
9
Date d'inscription
samedi 18 août 2018
Statut
Membre
Dernière intervention
20 août 2018

Re bonjour,

Comment faire pour enregistrer que c'est résolu? svp

Merci
Messages postés
23421
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
11 août 2020
6 284
Bonjour,

Sur l'engrenage, à droite de ton titre, pour mettre en résolu.
eric
Messages postés
9
Date d'inscription
samedi 18 août 2018
Statut
Membre
Dernière intervention
20 août 2018

Oui je l'ai testée, j'ai juste oubliée de préciser qu'il s'agit d'une matrice et qu'il faut donc pour valider la formule appuyer simultanément sur Shift + Ctrl + Entrée

Merci encore!