Mot de passe PHPMyAdmin
Résolu
Bonjour, j'ai installer phpmyadmin sur mon vps, et j'aimerais savoir quel est le compte et le mot de passe, j'ai essayer root et aucun mot de passe, root avec le mot de passe de la machine. J'ai essaye avec localhost et j'ai eu ça :
mysqli_real_connect(): (HY000/1045): Access denied for user 'localhost'@'localhost' (using password: YES)
comment puis-je connaître le mot de passe ?
mysqli_real_connect(): (HY000/1045): Access denied for user 'localhost'@'localhost' (using password: YES)
comment puis-je connaître le mot de passe ?
2 réponses
-
Bonjour,
(using password: YES)
Cela signifie que la propriétéAllowNoPassword
est àFalse
dans le fichier de config, donc il y a bien un mot de passe qui n'est pas vide.
Essayez les suivants:
ID:root
; MDP:root
;
ID:root
; MDP:password
;
Un des deux fonctionnent-ils ?-
-
Modérateur@PetitMinou12Pas un fichier, mais une méthode.
Il faut stopper le serveur MySQL, le démarrer avec un argument précis qui indique d'ignorer les mots de passe et de là, tu pourras te connecter sans aucun mot de passe et tu pourras changer le mot de passe root de MySQL.
Cela étant, ton VPS pouvant exploiter énormément de versions d'OS différents... ça serait bien de spécifier la distro que tu utilises ainsi que la version de ton serveur MySQL (ou MariaDB). ;-) -
@Judge_DTMon Vps est héberger chez omg serv et je suis sous Debian 9 et je crois que mon mysql est mariaDB
-
Modérateur@PetitMinou12Quelle version MariaDB ?
Pour le savoir, dans un terminal root (ou pas) :mysql -V
Tu auras le détail. -
@Judge_DTVoila la réponse dans le terminal :
mysql Ver 15.1 Distrib 10.1.26-MariaDB, for debian-linux-gnu (x86_64) using rea dline 5.2
-