Mot de passe PHPMyAdmin [Résolu/Fermé]

Signaler
Messages postés
65
Date d'inscription
dimanche 11 décembre 2016
Statut
Membre
Dernière intervention
6 août 2020
-
 KalySo -
Bonjour, j'ai installer phpmyadmin sur mon vps, et j'aimerais savoir quel est le compte et le mot de passe, j'ai essayer root et aucun mot de passe, root avec le mot de passe de la machine. J'ai essaye avec localhost et j'ai eu ça :

mysqli_real_connect(): (HY000/1045): Access denied for user 'localhost'@'localhost' (using password: YES)

comment puis-je connaître le mot de passe ?

2 réponses

Messages postés
609
Date d'inscription
dimanche 17 septembre 2017
Statut
Membre
Dernière intervention
25 février 2019
133
Bonjour,
(using password: YES) 

Cela signifie que la propriété
AllowNoPassword
est à
False
dans le fichier de config, donc il y a bien un mot de passe qui n'est pas vide.
Essayez les suivants:

ID:
root
; MDP:
root
;
ID:
root
; MDP:
password
;
Un des deux fonctionnent-ils ?
Messages postés
28653
Date d'inscription
vendredi 5 février 2010
Statut
Modérateur
Dernière intervention
9 octobre 2020
7 269 >
Messages postés
65
Date d'inscription
dimanche 11 décembre 2016
Statut
Membre
Dernière intervention
6 août 2020

"Shell>" indique que c'est à taper dans un "Shell" ... un terminal.. une ligne de commande.
Messages postés
65
Date d'inscription
dimanche 11 décembre 2016
Statut
Membre
Dernière intervention
6 août 2020
4 >
Messages postés
28653
Date d'inscription
vendredi 5 février 2010
Statut
Modérateur
Dernière intervention
9 octobre 2020

Ok, merci j'ai essayer, mais mon vps est en anglais et je crois que ça ne m'aide pas quelle sont les information à rentrer ? (j'ai suivi les étapes mais pas très bien compris), En tout cas ça à l'air de mieux marcher :

mysqli_real_connect(): (HY000/1698): Access denied for user 'root'@'localhost'
Messages postés
28653
Date d'inscription
vendredi 5 février 2010
Statut
Modérateur
Dernière intervention
9 octobre 2020
7 269 >
Messages postés
65
Date d'inscription
dimanche 11 décembre 2016
Statut
Membre
Dernière intervention
6 août 2020

Et bien, il suffit de taper
mysql_secure_install
dans une console root et de suivre la procédure, qui est en anglais.

Si tu ne sais pas suivre cette procédure qui est expliquée et avec les informations données durant la procédure, ça promet...

Il vas te demander le mot de passe actuelle, qui est vide, donc juste fait "enter" mais... c'est expliqué. Ensuite, il te demandera si tu veux changer le mot de passe root.. Il faut dire oui, tu changes le mot de passe root de MySQL et ensuite, tu valides et tu suis la procédure. à la fin, il faudra utiliser le mot de passe configuré ici pour te connecter en root sur MySQL/PhpMyAdmin ...
Messages postés
65
Date d'inscription
dimanche 11 décembre 2016
Statut
Membre
Dernière intervention
6 août 2020
4 >
Messages postés
28653
Date d'inscription
vendredi 5 février 2010
Statut
Modérateur
Dernière intervention
9 octobre 2020

Bon j'ai réussi a résoudre mon problème en créant un nouveau utilisateur avec ses commande

1) sudo mysql -p -u root
2) CREATE USER 'user'@'%' IDENTIFIED BY 'motdepasse';
3) GRANT ALL PRIVILEGES ON *.* TO 'user'@'%' WITH GRANT OPTION;

Je vous remercie de votre aide et désoler pour votre perte de temps considérable :D
>
Messages postés
65
Date d'inscription
dimanche 11 décembre 2016
Statut
Membre
Dernière intervention
6 août 2020

Merci beaucoup....
Messages postés
29734
Date d'inscription
mercredi 22 octobre 2003
Statut
Modérateur
Dernière intervention
12 octobre 2020
2 836
Bonjour

user 'localhost'@'localhost' ??
Ton user c'est localhost ?
Cela m'étonne.... a mon avis commence par vérifier le login â utiliser..
Messages postés
65
Date d'inscription
dimanche 11 décembre 2016
Statut
Membre
Dernière intervention
6 août 2020
4
Non je crois qu'en fait c'est root