Concatener cellules avec conditions

Résolu/Fermé
Messages postés
2
Date d'inscription
mercredi 25 juillet 2018
Statut
Membre
Dernière intervention
26 juillet 2018
-
Messages postés
2
Date d'inscription
mercredi 25 juillet 2018
Statut
Membre
Dernière intervention
26 juillet 2018
-
Bonjour,

Je souhaite concatener 2cellules d'une même colonne en fonction des 4 premiers caractères de chaque cellule. Par exemple, mes cellules ont toutes un contenu qui commence par 4600, 4601, 3300 ou 3301. Je souhaite concatèner la cellule qui continent 4600 avec celle qui contient 4601 et qui est placée tout de suite en dessous. Idem pour les cellules avec les valeurs 3300 et 3301. Si une cellule qui contient 4600 est suivie d'une qui contient aussi 4600, alors elles ne doivent pas être Concatenees. Idem pour les valeurs 3300 et 3301.
J'espère être assez claire.
Merci pour votre aide.

1 réponse

Messages postés
26411
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
27 janvier 2022
6 191
Bonjour

avec la liste des codes en colonne A à partir de A2
la formule qui pourrait faire l'affaire, en A3 à tirer sur la hauteur:
=SI(GAUCHE(A2;4)+1=GAUCHE(A3;4)*1;A2&A3;"")

si ça ne convient pas, revenez en déposant une liste de vos codes et quelques exemples des résultats attendus ici:
http://mon-partage .fr
et coller ici le lien créé sur les site

crdlmnt



Messages postés
2
Date d'inscription
mercredi 25 juillet 2018
Statut
Membre
Dernière intervention
26 juillet 2018

Bonjour,
Super. Je vais tester ce soir. Merci beaucoup pour votre réponse rapide.
Cordialement