Problème avec apt-get install bison libssl-dev lib

Résolu/Fermé
Signaler
Messages postés
45
Date d'inscription
vendredi 13 juillet 2018
Statut
Membre
Dernière intervention
23 novembre 2021
-
Messages postés
45
Date d'inscription
vendredi 13 juillet 2018
Statut
Membre
Dernière intervention
23 novembre 2021
-
Bonjour,
quand je tape la commande apt-get install bison libssl-dev libeditline0 libeditline-devlibedit-dev libnewt-dev . Je reçoit le message suivant:

Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
E: Impossible de trouver le paquet libeditline-devlibedit-dev

Aidez moi svp.merci



4 réponses

Messages postés
36324
Date d'inscription
dimanche 7 novembre 2010
Statut
Contributeur
Dernière intervention
27 janvier 2021
6 587
Salut,
E: Impossible de trouver le paquet libeditline-devlibedit-dev
Essaie plutôt en mettant un espace entre
libeditline-dev
et
libedit-dev
;-\

apt-get install bison libssl-dev libeditline0 libeditline-dev libedit-dev libnewt-dev

0
Messages postés
45
Date d'inscription
vendredi 13 juillet 2018
Statut
Membre
Dernière intervention
23 novembre 2021

Merci de m'avoir reponduj 'ai pu resoudre le problème et j ai encore
un autre probleme de ce genre
0
Messages postés
45
Date d'inscription
vendredi 13 juillet 2018
Statut
Membre
Dernière intervention
23 novembre 2021

Lorque je tape cette commande apt-get install unixodbc unixodbc-dev libmyodbc libmysqlclient15-dev je reçoit ce message:
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
Aucune version du paquet libmyodbc n'est disponible, mais il existe dans la base
de données. Cela signifie en général que le paquet est manquant, qu'il est devenu obsolète
ou qu'il n'est disponible que sur une autre source
Le paquet « libmyodbc » n'a pas de version susceptible d'être installée
E: Impossible de trouver le paquet libmysqlclient15-dev

Besoin de votre aide.Merci d' avance
0
Messages postés
36324
Date d'inscription
dimanche 7 novembre 2010
Statut
Contributeur
Dernière intervention
27 janvier 2021
6 587 >
Messages postés
45
Date d'inscription
vendredi 13 juillet 2018
Statut
Membre
Dernière intervention
23 novembre 2021

Que renvoie la commande :
apt-cache search libmysqlclient
?
0
Messages postés
45
Date d'inscription
vendredi 13 juillet 2018
Statut
Membre
Dernière intervention
23 novembre 2021

root@debian:~# apt-cache search libmysqlclient
libglpk40 - linear programming kit with integer (MIP) support
libcrypt-mysql-perl - Perl module to emulate the MySQL PASSWORD() function
libmariadbclient-dev-compat - MariaDB database development files (libmysqlclient compatibility)
default-libmysqlclient-dev - MySQL database development files (metapackage)
0
Messages postés
36324
Date d'inscription
dimanche 7 novembre 2010
Statut
Contributeur
Dernière intervention
27 janvier 2021
6 587 >
Messages postés
45
Date d'inscription
vendredi 13 juillet 2018
Statut
Membre
Dernière intervention
23 novembre 2021

default-libmysqlclient-dev - MySQL database development files (metapackage) 
Perso j'essaierai d'installer ce paquet.
libmariadbclient-dev-compat - MariaDB database development files (libmysqlclient compatibility) 
Ou celui-ci.
0
Messages postés
153
Date d'inscription
mercredi 4 avril 2007
Statut
Membre
Dernière intervention
16 juillet 2018
16
Salut,
Vérifies aussi ta source de paquets dans /etc/apt/sources.list.
Rassures toi donc que tu pointes sur la bonne source et que celle ci est activée.
Bonne chance.
0
Messages postés
45
Date d'inscription
vendredi 13 juillet 2018
Statut
Membre
Dernière intervention
23 novembre 2021

Merci Rodryo j'ai reussir a resoudre le problème.et j'ai une autre preocupation
0
Messages postés
45
Date d'inscription
vendredi 13 juillet 2018
Statut
Membre
Dernière intervention
23 novembre 2021

Lorque je tape cette commande apt-get install unixodbc unixodbc-dev libmyodbc libmysqlclient15-dev je reçoit ce message:
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
Aucune version du paquet libmyodbc n'est disponible, mais il existe dans la base
de données. Cela signifie en général que le paquet est manquant, qu'il est devenu obsolète
ou qu'il n'est disponible que sur une autre source
Le paquet « libmyodbc » n'a pas de version susceptible d'être installée
E: Impossible de trouver le paquet libmysqlclient15-dev
0
Messages postés
153
Date d'inscription
mercredi 4 avril 2007
Statut
Membre
Dernière intervention
16 juillet 2018
16
Salut,
Là aussi, c'est généralement un soucis avec la sources des paquets (Absente, déactivée...etc).
Rassure toi d'avoir la bonne source de paquets qui te fournit ce paquet, que cette source est active. Sinon, ajoute là et à la fin, n'oublies pas de faire un apt update.
Tu peux aussi nous faire voir à quoi ressemble ton fichier /etc/apt/sources.list.
Bonne chance à toi.
0
Messages postés
45
Date d'inscription
vendredi 13 juillet 2018
Statut
Membre
Dernière intervention
23 novembre 2021

deb http://deb.debian.org/debian/ stretch main
deb-src http://deb.debian.org/debian/ stretch main
deb http://security-cdn.debian.org/debian-security/ stretch/updates main
deb-src http://security-cdn.debian.org/debian-security/ stretch/updates main
deb http://deb.debian.org/debian/ stretch-updates main
deb-src http://deb.debian.org/debian/ stretch-updates main

Désolé j ' avais un problème de connexion
0
Messages postés
45
Date d'inscription
vendredi 13 juillet 2018
Statut
Membre
Dernière intervention
23 novembre 2021

zip31 et Rodryo86 vraiament merci beaucoup j 'ai resoudre le problème il fallait taper la commande apt-get install unixodbc unixodbc-dev libreoffice-base-drivers libmariadbclient-dev-compat au lieu de ce que j'ai taper plus haut
0