Liste déroulante avec fonction SI [Résolu/Fermé]

Signaler
Messages postés
6
Date d'inscription
jeudi 21 juin 2018
Statut
Membre
Dernière intervention
28 mars 2019
-
Messages postés
6
Date d'inscription
jeudi 21 juin 2018
Statut
Membre
Dernière intervention
28 mars 2019
-
Bonjour,
si c'est un peu en retard dans cette publication, mais j'ai besoin d'utiliser les élément d'une liste déroulante dans une fonction SI. comment je peux le faire?

merci

1 réponse

Messages postés
25213
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
7 août 2020
5 394
Bonjour
à part placer la liste dans une cellule et la fonction dans une autre avec la formule qui fera référence à cette cellule, je ne vois pas
crdlmnt
Messages postés
6
Date d'inscription
jeudi 21 juin 2018
Statut
Membre
Dernière intervention
28 mars 2019

Mon problème est dans la formule qui fera référence à la liste déroulante.
étant donnée que ma liste déroulante nommée " Evaluation" contient le mot non conforme j'ai écrit ça
=IF( Evaluation[Evaluation]="Non conforme";"0";"66")
mais j'obtient toujours #Value!
Messages postés
25213
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
7 août 2020
5 394
Re
cette formule devrait donner un résultat, mais je ne vois à quoi elle peut bien servir

=IF(COUNTIF(Evaluation;"non conforme");0;66)

si bien sur dans votre version anglaise, le séparateur est bien le ; et pas ,

mais que voulez vous faire excatement?

crdlmnt
Messages postés
6
Date d'inscription
jeudi 21 juin 2018
Statut
Membre
Dernière intervention
28 mars 2019

je veux attribuer à chaque élément sélectionné de ma liste déroulante une valeur.
par exemple: si je sélectionne Conforme il m'affiche ans une autre colonne 100 si non si je sélectionne non conforme il m'affiche 0 si non si je sélectionne autre chose il m'affiche ... ect
Cordialement
Messages postés
25213
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
7 août 2020
5 394
Alors en ligne avec votre liste déroulante, inscrivez dans chaque cellule la valeur que vous donnez à cette ligne
par exemple(à adapter) , menu de la liste de A1 à A10, placez en B1:B10 la valeur de chaque élément

ensuite si vous placez le menu déroulant en C1, vous pouvez placer en D1 cette formule:

=SIERREUR(RECHERCHEV(C1;$A$1:$B$10;2;0);"")

elle vous renverra la valeur de B sur la ligne où se trouve en A la valeur de C

notez que le code SIERREUR ne fonctionne qu'à partir d'Excel 2007. Si ce n'est pas le cas, revenez
crdlmnt
Messages postés
6
Date d'inscription
jeudi 21 juin 2018
Statut
Membre
Dernière intervention
28 mars 2019

Merci beaucoup Vaucluse, ça marche la fonction
Cordialement