Liste déroulante avec fonction SI

Résolu/Fermé
maynou24
Messages postés
6
Date d'inscription
jeudi 21 juin 2018
Statut
Membre
Dernière intervention
28 mars 2019
- 21 juin 2018 à 11:53
maynou24
Messages postés
6
Date d'inscription
jeudi 21 juin 2018
Statut
Membre
Dernière intervention
28 mars 2019
- 21 juin 2018 à 23:04
Bonjour,
si c'est un peu en retard dans cette publication, mais j'ai besoin d'utiliser les élément d'une liste déroulante dans une fonction SI. comment je peux le faire?

merci
A voir également:

1 réponse

Vaucluse
Messages postés
26495
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
8 avril 2022
6 272
21 juin 2018 à 12:27
Bonjour
à part placer la liste dans une cellule et la fonction dans une autre avec la formule qui fera référence à cette cellule, je ne vois pas
crdlmnt
0
maynou24
Messages postés
6
Date d'inscription
jeudi 21 juin 2018
Statut
Membre
Dernière intervention
28 mars 2019

21 juin 2018 à 13:27
Mon problème est dans la formule qui fera référence à la liste déroulante.
étant donnée que ma liste déroulante nommée " Evaluation" contient le mot non conforme j'ai écrit ça
=IF( Evaluation[Evaluation]="Non conforme";"0";"66")
mais j'obtient toujours #Value!
0
Vaucluse
Messages postés
26495
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
8 avril 2022
6 272
21 juin 2018 à 14:01
Re
cette formule devrait donner un résultat, mais je ne vois à quoi elle peut bien servir

=IF(COUNTIF(Evaluation;"non conforme");0;66)

si bien sur dans votre version anglaise, le séparateur est bien le ; et pas ,

mais que voulez vous faire excatement?

crdlmnt
0
maynou24
Messages postés
6
Date d'inscription
jeudi 21 juin 2018
Statut
Membre
Dernière intervention
28 mars 2019

21 juin 2018 à 14:16
je veux attribuer à chaque élément sélectionné de ma liste déroulante une valeur.
par exemple: si je sélectionne Conforme il m'affiche ans une autre colonne 100 si non si je sélectionne non conforme il m'affiche 0 si non si je sélectionne autre chose il m'affiche ... ect
Cordialement
0
Vaucluse
Messages postés
26495
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
8 avril 2022
6 272
21 juin 2018 à 14:31
Alors en ligne avec votre liste déroulante, inscrivez dans chaque cellule la valeur que vous donnez à cette ligne
par exemple(à adapter) , menu de la liste de A1 à A10, placez en B1:B10 la valeur de chaque élément

ensuite si vous placez le menu déroulant en C1, vous pouvez placer en D1 cette formule:

=SIERREUR(RECHERCHEV(C1;$A$1:$B$10;2;0);"")

elle vous renverra la valeur de B sur la ligne où se trouve en A la valeur de C

notez que le code SIERREUR ne fonctionne qu'à partir d'Excel 2007. Si ce n'est pas le cas, revenez
crdlmnt
0
maynou24
Messages postés
6
Date d'inscription
jeudi 21 juin 2018
Statut
Membre
Dernière intervention
28 mars 2019

21 juin 2018 à 23:04
Merci beaucoup Vaucluse, ça marche la fonction
Cordialement
0