Utilisation formule si

Résolu/Fermé
Signaler
Messages postés
14
Date d'inscription
mardi 22 mai 2018
Statut
Membre
Dernière intervention
30 mai 2018
-
Messages postés
14
Date d'inscription
mardi 22 mai 2018
Statut
Membre
Dernière intervention
30 mai 2018
-
Bonjour,

Comment utiliser la formule ci-dessous pour 4 cellules (A1, B1, C1, D1)

=SI(ET(A1<>"";B1<>"");"Une seule réponse SVP";

D'avance merci

Arnaud

2 réponses

Messages postés
13328
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
15 janvier 2022
2 322
Bonsoir Arnaud

Plutôt qu'une syntaxe compliquée de SI (car il faut envisager les 6 possibilités de 2 cellules remplies) passe plutôt par un NBVAL pour compter les cellules non vides de la plage, si le résultat est supérieur à 1 c'est pas bon :
=SI(NBVAL(A1:D1)>1;"Une seule réponse SVP"; ...

Cdlmnt
Via

1
Messages postés
14
Date d'inscription
mardi 22 mai 2018
Statut
Membre
Dernière intervention
30 mai 2018

Bonjour VIA55

Excellent !!!

Merci pour la rapidité de votre réponse.

Bien à vous

Arnaud
0
Messages postés
33669
Date d'inscription
mercredi 2 mai 2007
Statut
Modérateur
Dernière intervention
16 janvier 2022
8 330
Bonjour,

Ou (exclusif) mais c'est déjà plus long

=SI(OUX(A1<>"";B1<>"";C1<>"";D1<>"");"OK";"Une et une seule réponse")

Cdlt
0