Formule totalisation en fonction de la valeur d'une cellule

Résolu/Fermé
marckherv Messages postés 87 Date d'inscription mardi 1 août 2017 Statut Membre Dernière intervention 20 juin 2021 - 30 déc. 2017 à 18:04
marckherv Messages postés 87 Date d'inscription mardi 1 août 2017 Statut Membre Dernière intervention 20 juin 2021 - 30 déc. 2017 à 18:50
Bonjour,

Je souhaiterai totaliser des montants entre eux en fonction d'une valeur
Je m'explique
colonne A: famille (de 0 à 99)
colonne B: un identifiant
colonne C: la valeur à totaliser pour chaque famille
colonne D: le sous-total par famille (à inscrire pour la ligne du dernier article de la famille)-> cellule en jaune sur mon fichier

colonne E: le nombre d'article dans la famille (à inscrire pour la ligne du dernier article de la famille)-> cellule en jaune sur mon fichier

et cerise sur le gâteau: pouvoir synthétiser le résultat ds colonne D et E dans un tableau


Merci pour votre aide

https://www.cjoint.com/c/GLErcmeFrHj

3 réponses

yclik Messages postés 3031 Date d'inscription vendredi 25 juillet 2014 Statut Membre Dernière intervention 3 décembre 2022 1 366
30 déc. 2017 à 18:15
Bonsoir
Voir du côté des tableaux croisés dynamiques
ce qui donnerait ceci
0
marckherv Messages postés 87 Date d'inscription mardi 1 août 2017 Statut Membre Dernière intervention 20 juin 2021
30 déc. 2017 à 18:49
merci, je procède comment?
0
via55 Messages postés 13977 Date d'inscription mercredi 16 janvier 2013 Statut Membre Dernière intervention 4 décembre 2022 2 526
Modifié le 30 déc. 2017 à 18:25
Bonjour,

En E7 la formule =SI(NB.SI($A$7:A7;A7)=NB.SI(A:A;A7);NB.SI(A:A;A7);"") à étirer vers le bas
E n D7 la formule =SI(E7<>"";SOMME.SI(A:A;A7;C:C);"") à étirer vers le bas

Cdlmnt
Via

"L'imagination est plus importante que le savoir."    A. Einstein
0
marckherv Messages postés 87 Date d'inscription mardi 1 août 2017 Statut Membre Dernière intervention 20 juin 2021
30 déc. 2017 à 18:50
merci
0
Vaucluse Messages postés 26495 Date d'inscription lundi 23 juillet 2007 Statut Contributeur Dernière intervention 8 avril 2022 6 285
30 déc. 2017 à 18:21
Bonjour
curieux, Via (salut, bonne fin d'année)
moi j'avais fait ça :-))
https://mon-partage.fr/f/jzXBPL1e/
crdflmnt
0
via55 Messages postés 13977 Date d'inscription mercredi 16 janvier 2013 Statut Membre Dernière intervention 4 décembre 2022 2 526
Modifié le 30 déc. 2017 à 18:25
Hello Vaucluse, bonne fin d'année également ☺
On a des formules similaires, simplement pour toi c'est la colonne D qui détermine si on calcule et moi la E (j'avais écris F par erreur dans ma réponse, j'ai corrigé)
0
marckherv Messages postés 87 Date d'inscription mardi 1 août 2017 Statut Membre Dernière intervention 20 juin 2021
30 déc. 2017 à 18:50
Merci
0