Somme avec COLONNE() [Résolu/Fermé]

Signaler
Messages postés
898
Date d'inscription
mercredi 8 avril 2009
Statut
Membre
Dernière intervention
7 août 2018
-
Messages postés
898
Date d'inscription
mercredi 8 avril 2009
Statut
Membre
Dernière intervention
7 août 2018
-
Bonjour,
je dois faire un truc tout bête: faire descendre une formule non pas seulement en faisant aller les chiffres vers le bas (de ligne) mais en faisant aller aussi les colonnes vers la droite.
Ma formule utilise des valeurs dans un autre tableau. Quand je la fais descendre, elle fait tout descendre: A1, A2, A3... Mais j'ai besoin qu'elle fasse descendre els chiffres (1...2...3....) et qu'elle bouge les lettres aussi vers la droite (A..B...C..).
Faut il utiliser COLONNE() ?

Le lien a été crée : http://www.cjoint.com/c/GJdworTTFhT
Le prb est dans la colonne STDEV ici. j'ai mis 2 infos en jaune

merci bcp!!

1 réponse

Messages postés
52729
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
25 novembre 2020
14 669
Bonsoir, TO127.
Pas simple, ton affaire !
Après de nombreuses tentatives, je n'ai trouvé une méthode qu'à condition d'ajouter des codes en A13:B32, qui me permettent d'indexer les N° de lignes et de colonnes.
Ma formule pour la colonne Average, cellules D13:D32, est alors
=MOYENNE(INDEX(plaj;LIGNE()-A:A;COLONNE()+B:B):
INDEX(plaj;LIGNE()-A:A+2;COLONNE()+B:B))

dans laquelle plaj est le nom de la plage A1:M9 ...

Est-ce qu'une telle façon
de faire te conviendrait ?




Messages postés
898
Date d'inscription
mercredi 8 avril 2009
Statut
Membre
Dernière intervention
7 août 2018
82
Hmmm, mais alors on intervient pas dans la colonne E avec al formule?
j'avais pensé utiliser COLONNE() mais je savais pas ocmment
Messages postés
52729
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
25 novembre 2020
14 669 >
Messages postés
898
Date d'inscription
mercredi 8 avril 2009
Statut
Membre
Dernière intervention
7 août 2018

Ecoute : J'ai passé un certain temps pour trouver une solution possible.

Je te l'ai présentée en te demandant si, pour la colonne Average, cellules D13:D32, cette façon de faire te conviendrait.
J'attends donc ta réponse avant de m'intéresser à la colonne STEDV, si tu n'arrives pas tout seul à trouver la bonne formule, en t'inspirant de ce que j'ai déjà fait ...
Messages postés
898
Date d'inscription
mercredi 8 avril 2009
Statut
Membre
Dernière intervention
7 août 2018
82
bonjour ! désolé, réponse tardive. pas d'internet à proximité du cercle polaire canadien. Ca me semble uen solution oui. Je pense réussir à maitriser ce COLONNE() bientôt. Merci bcp!