Somme si en comparant 2 colonne de date

Résolu/Fermé
Signaler
Messages postés
413
Date d'inscription
jeudi 28 août 2008
Statut
Membre
Dernière intervention
9 novembre 2021
-
Messages postés
413
Date d'inscription
jeudi 28 août 2008
Statut
Membre
Dernière intervention
9 novembre 2021
-
Bonjour,

Bonjour,
J'ai une colonne A avec des dates, une colonne B avec des et une colonne C avec une quantité.
Je voudrais faire un somme.si sur C, si A2 et supérieur à B2, A3 supérieur à B3...
Comment faire ?

4 réponses

Messages postés
2755
Date d'inscription
jeudi 2 juillet 2015
Statut
Membre
Dernière intervention
10 janvier 2022
1 713
Bonjour,

Voici la formule qui pourrait vous correspondre :
=SOMME.SI(A:A;">"&B:B;C:C)

Si cela ne fonctionne pas comme vous le souhaitez faites un signe
0
Messages postés
13350
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
21 janvier 2022
2 327
Bonjour

Essaie ceci :
=SOMMEPROD((A1:A100>B1:B100)*(C1:C100))

Cdlmnt
Via
0
Messages postés
413
Date d'inscription
jeudi 28 août 2008
Statut
Membre
Dernière intervention
9 novembre 2021
84
Comment je gère si on ne connaît pas la limite du tableau ?
Car en faisant =SOMMEPROD((A:A>B:B)*(C:C))
Cà me retourne une erreur
0
Messages postés
413
Date d'inscription
jeudi 28 août 2008
Statut
Membre
Dernière intervention
9 novembre 2021
84
Bon j'ai adapté à mon fichier et je n'ai pris que les 2 premières lignes.
L'une respecte, pas l'autre.
Cela devrait me retourner 1 et çà me retourne 2.

La formule :
=SOMME.SI(C2:C3;">"&Q2:Q3;K2:K3)
0
Messages postés
2755
Date d'inscription
jeudi 2 juillet 2015
Statut
Membre
Dernière intervention
10 janvier 2022
1 713
En effet je viens de voir qu'il y a une erreur dans la condition et cela ne fonctionne pas....

Vous pouvez prendre la formule de Via55 et mettre des bornes supérieur très étendus si vous ne connaissez pas la limite du tableau
0
Messages postés
413
Date d'inscription
jeudi 28 août 2008
Statut
Membre
Dernière intervention
9 novembre 2021
84
Juste un dernier point, cela fonctionne grâce à vos différentes contribution via cette formule :
=SOMMEPROD((BDD!P2:P770<>"")*(BDD!C2:C770<(BDD!P2:P770)-15)*(BDD!J2:J770))


Donc la je somme J2 à J770

Je veux quasiment la même chose donc avec les mêmes condition à la différence que je ne veux pas une somme mais une moyenne.

Que dois-je changer ?
0
Messages postés
26404
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
21 janvier 2022
6 185
Bonjour
essayez avec:
=SOMMEPROD((BDD!P2:P770<>"")*(BDD!C2:C770<(BDD!P2:P770)-15)*(BDD!J2:J770))/=SOMMEPROD((BDD!P2:P770<>"")*(BDD!C2:C770<(BDD!P2:P770)-15))

c'est à dire en enlevant dans le diviseur l'item champ à sommer, le diviseur comptera alors le nombre de lignes correspondant au résultat

crdlmnt
0
Messages postés
2755
Date d'inscription
jeudi 2 juillet 2015
Statut
Membre
Dernière intervention
10 janvier 2022
1 713 >
Messages postés
26404
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
21 janvier 2022

Bonjour Vaucluse:)

Tu ne dois pas enlever le = du diviseur? sinon ça rapporte une erreur si je ne me trompe pas
0
Messages postés
26404
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
21 janvier 2022
6 185 >
Messages postés
2755
Date d'inscription
jeudi 2 juillet 2015
Statut
Membre
Dernière intervention
10 janvier 2022

diablo
effectivement, sans le égal (copier coller mal nettoyé)

=SOMMEPROD((BDD!P2:P770<>"")*(BDD!C2:C770<(BDD!P2:P770)-15)*(BDD!J2:J770))/SOMMEPROD((BDD!P2:P770<>"")*(BDD!C2:C770<(BDD!P2:P770)-15))


bidounet
et ça renvoie quoi comme date?
il est possible qu'en fonction des éléments de la formule Excel format automatiquement en date. Essayez de reformatez la cellule en standard ou autre selon besoins.

crdlmnt
0
Messages postés
413
Date d'inscription
jeudi 28 août 2008
Statut
Membre
Dernière intervention
9 novembre 2021
84
Cà me renvoi une date !
P est une colonne de date, C également et J des quantités
0
Messages postés
413
Date d'inscription
jeudi 28 août 2008
Statut
Membre
Dernière intervention
9 novembre 2021
84
Je me suis mal exprimé, dans mon premier cas je voulais effectivement sommé la colonne J en fonction des critères dans la formule.
Dans ma cellule d'à côté au lieu de vouloir sommé J, je veux faire la moyenne en jour entre P et C si cela respecte les critères.
0