Fonction SI, contient une chaine de caractère

Résolu/Fermé
Signaler
Messages postés
12
Date d'inscription
vendredi 13 avril 2012
Statut
Membre
Dernière intervention
26 août 2014
-
Messages postés
12
Date d'inscription
vendredi 13 avril 2012
Statut
Membre
Dernière intervention
26 août 2014
-
Bonjour à tous,

Ça m'embête un peu de venir poster ici, mais je tourne en rond, donc si quelqu'un peut m'éclairer de ces lumières, je lui en serait reconnaissant :D

Alors voilà, l'idée principale serais de faire un Gantt sur Excel, jusque là pas de problème.

Je rencontre simplement une difficulté pour faire un "formatage conditionnel".

En gros, ma colonne "A" contient différente tâches comme Action, Présentation, Autre ...

Et j'aimerais conditionner (en jaune par exemple) les tâches qui commencent par "Action".

Seul hic, je n'obtiens pas le résultat attendu.

J'ai essayé de faire un petit test logique dans une cellule annexe et là encore le résultat est faussé. ( je n'obtiens que "FALSE")
Je ne trouve pas mon erreur :/

=IF($A49="*Action commerciales *";"TRUE";"FALSE")

Dans l'attente de vous lire,

Cordialement,

Rémi

PS: Office 2013 en anglais
A voir également:

2 réponses

Messages postés
26407
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
23 janvier 2022
6 186
Bonjour

version française, utilisez NB.SI: (COUNTIF, je crois)

=SI(NB.SI(A49;"*Action*");True;False)

crdlmnt

ps
pour une mise en forme conditionnelle, mieux vaut éviter le SI
dans la formule de MFC

=NB.SI(A49;"*Action*")

suffira


Errare humanum est, perseverare diabolicum
2
Messages postés
12
Date d'inscription
vendredi 13 avril 2012
Statut
Membre
Dernière intervention
26 août 2014

Oui en effet, je viens de trouvé sur un site annexe

=IF(COUNTIF($A1;"*Action commerciales*");"oui";"non")

Merci bien , bonne journée
0
Messages postés
12
Date d'inscription
vendredi 13 avril 2012
Statut
Membre
Dernière intervention
26 août 2014

Ok , =IF(COUNTIF($A1;"*Action commerciales*");"oui";"non")

je viens de trouvé, merci à tous ^^
0