Afficher #N/A si résultat = 0 [Résolu/Fermé]

Signaler
Messages postés
15
Date d'inscription
vendredi 8 septembre 2017
Statut
Membre
Dernière intervention
9 septembre 2017
-
Messages postés
15
Date d'inscription
vendredi 8 septembre 2017
Statut
Membre
Dernière intervention
9 septembre 2017
-
Bonjour,

J'ai actuellement la formule ci dessous :
=($EC$21*EF21+$EC$17*EF17+$EC$12*EF12)/3

Je veux toutefois que si le résultat est = 0 alors qu'il m'affiche #N/A. J'ai essayé la formule ci dessous qui me renvoi 0 au lieu de #N/A.

=SIERREUR($EC$21*EF21+$EC$17*EF17+$EC$12*EF12;#N/A)/3
J'ai également essayé :
=SIERREUR($EC$21*EF21+$EC$17*EF17+$EC$12*EF12)/3);#N/A)

Si vous pouvez m'aider je suis preneuse :)

2 réponses

Messages postés
13006
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
8 mai 2021
2 188
Bonsoir

La formule avec SIERREUR ne détecte aucune erreur puisque le résultat 0 est une possibilité de calcul pas une erreur

Essaie plutôt =SI(($EC$21*EF21+$EC$17*EF17+$EC$12*EF12)/3=0;"erreur";($EC$21*EF21+$EC$17*EF17+$EC$12*EF12)/3)

Cdlmnt
Via

"L'imagination est plus importante que le savoir."    A. Einstein
Messages postés
24053
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
16 mai 2021
6 768
voire même :
=SI(($EC$21*EF21+$EC$17*EF17+$EC$12*EF12)/3=0;NA();($EC$21*EF21+$EC$17*EF17+$EC$12*EF12)/3)

;-)
Messages postés
15
Date d'inscription
vendredi 8 septembre 2017
Statut
Membre
Dernière intervention
9 septembre 2017

Merci de vos retours toujours aussi rapide et efficace !

Je ne sais pas comment je ferai sans votre support, merci encore

Mon problème est résolu grâce à vos conseils :)
Messages postés
15
Date d'inscription
vendredi 8 septembre 2017
Statut
Membre
Dernière intervention
9 septembre 2017

il me semble mais à l'évidence non

Idem avec : =SI(SOMMEPROD(EG13:EG16;$EC$13:$EC$16)=0;NA())
Idem avec : =SI(SOMMEPROD(EG13:EG16)=0;N/A();($EC$13:$EC$16))

:(
Messages postés
24053
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
16 mai 2021
6 768
il me semble
tu plaisantes j'espère ?
=si(ta_formule=0;na();ta_formule)
Messages postés
15
Date d'inscription
vendredi 8 septembre 2017
Statut
Membre
Dernière intervention
9 septembre 2017

Nous n'avons visiblement pas la même expertise dans ce domaine :)

En quoi cette formule ne fonctionne pas : =SI(SOMMEPROD(EE13:EE16;EC13:EC16=0;"NA"())/EE13:EE16) ??

Même si ceal te semble évident, cela ne l'est pas pour tous ;-)
Messages postés
24053
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
16 mai 2021
6 768
Pas besoin d'être expert pour recopier un modèle, c'est un exercice qu'on fait faire aux enfants.
Elle ne fonctionne pas parce qu'elle ne veut rien dire comme te le dit excel.
Messages postés
15
Date d'inscription
vendredi 8 septembre 2017
Statut
Membre
Dernière intervention
9 septembre 2017

merci de ton retour :) Cela m'aide moins que précédemment et je vais continuer à solliciter de l'aide.
Encore merci pour ta précieuse aide. Vous restez tous autant que vous êtes d'un support très apprécié.