Rendre invisible une textbox à l'ouverture du classeur [Résolu/Fermé]

Signaler
Messages postés
94
Date d'inscription
mardi 5 novembre 2013
Statut
Membre
Dernière intervention
16 octobre 2017
-
Messages postés
12795
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
29 octobre 2020
-
Bonjour à tous,

J'essais de rendre invisibles mes textbox à l'ouverture de mon classeur mais mon code ne fonctionne pas, je l'ai placé dans ThisWorkbook :

Private Sub Workbook_Open()

  Application.OnKey "{ESCAPE}", "" ' touche Echap inactive
  Application.DisplayFullScreen = True ' affichage plein écran
  ActiveWindow.DisplayWorkbookTabs = False ' onglets masqués
  ActiveWindow.DisplayHorizontalScrollBar = False 'barre de défilement masquée
  ActiveWindow.DisplayVerticalScrollBar = False 'barre de défilement masquée
  CacheBOutils ' masque les barres d'outils
  ActiveWindow.Zoom = 100
  ActiveSheet.ScrollArea = "A1:O32"
  
     
  With Me.TextBox1.Visible = False
     Me.TextBox2.Visible = False
     Me.TextBox3.Visible = False
     Me.TextBox4.Visible = False
     Me.TextBox5.Visible = False
  End With
  
  With Worksheets("KiKiFé").Me.ComboBox2
  .Select
  .Activate
  End With

End Sub

Sub CacheBOutils()
  Dim CmdB As CommandBar
  For Each CmdB In Application.CommandBars
    CmdB.Enabled = False
  Next CmdB
End Sub


Ce n'est pas la bonne façon de l'écrire peut être?

1 réponse

Messages postés
12795
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
29 octobre 2020
2 050
Bonjour,

Apparemment c'est ton WITH qui est mal écrit, essaye ceci :
  With Me.
     TextBox1.Visible = False
     .TextBox2.Visible = False
     .TextBox3.Visible = False
     .TextBox4.Visible = False
     .TextBox5.Visible = False
  End With

Cdlmnt
Via