Fonction de recherche

Résolu/Fermé
Messages postés
11
Date d'inscription
mardi 23 février 2010
Statut
Membre
Dernière intervention
23 septembre 2017
-
Messages postés
11
Date d'inscription
mardi 23 février 2010
Statut
Membre
Dernière intervention
23 septembre 2017
-
Bonjour,

Je suis sur Excel 2016, pour mes études, j'ai fait un dossier Excel avec les pages nommées de "A" à "Z" pour faire un lexique, j'ai créé une 27ème page nommée "Recherche". La page "A" comme les autres pages sont créées ainsi :

Colonne A "Mots"; Colonne B "Définition", Colonne C "Exemple".
Peut-être vais-je ajouter une colonne D "Source" si j'en vois l'utilité.

J'aimerai lorsque je suis sur cette dernière page "Recherche", pouvoir taper un mot qui se trouverait dans une des autres pages et d'avoir la définition, l'exemple et éventuellement la source, qui s'affichent à côté.

Je vous remercie par avance

2 réponses

Messages postés
615
Date d'inscription
mercredi 5 octobre 2016
Statut
Membre
Dernière intervention
25 mai 2021
52
Bonjour,

une piste en considérant que le mot recherché soit en A1 :
=RECHERCHEV(A1;INDIRECT(GAUCHE(A1;1)&"!A1:D36000");2;0)
A ecrire dans la colonne B pour chercher la définition,
pour C remplacer le 2 par un 3 pour chercher dans la 3eme colonne
... etc
Le D36000 est également à ajuster selon le nombre de lignes des tableaux des différentes feuilles

Quand on ne dispose que d'un marteau tout les problèmes ressemblent à un clou
Messages postés
11
Date d'inscription
mardi 23 février 2010
Statut
Membre
Dernière intervention
23 septembre 2017

Désolée du manque de réponse, j'ai testé votre solution, un peu difficile à mettre en place, mais je vous remercie :)
Messages postés
8539
Date d'inscription
dimanche 13 juin 2010
Statut
Membre
Dernière intervention
20 juillet 2021
1 731
Bonjour,

Pourquoi ne pas utiliser qu'un seul onglet ?
Avec plus d'un million de lignes, c'est suffisant pour un dictionnaire

La fonction filtre est assez puissante pour traiter un dictionnaire complet, plus besoin de l'onglet recherche !

Tu peux éventuellement ajouter une colonne 1ère lettre avec la fonction GAUCHE()
Messages postés
11
Date d'inscription
mardi 23 février 2010
Statut
Membre
Dernière intervention
23 septembre 2017

Désolée du manque de réponse, je vous remercie pour votre solution :)