Wifi sur machine virtuelle linux

Résolu/Fermé
Signaler
Messages postés
211
Date d'inscription
lundi 14 août 2017
Statut
Membre
Dernière intervention
4 novembre 2021
-
Messages postés
101887
Date d'inscription
lundi 16 juillet 2001
Statut
Membre
Dernière intervention
23 janvier 2022
-
Bonjour,

J'ai installé le WiFi sur ma machine hôte (Windows) pour pouvoir l'utiliser avec Ubuntu (que j'utilise en machine virtuelle avec VirtualBox).
Dans les paramètres réseaux de cette dernière, j'ai mis: mode d'accès réseau: NAT"

Cependant, lorsque je lance une commande ifconfig, cette dernière ne m'affiche que ma connexion éthernet (alors que j'ai débranché le câble) et ma connexion locale... mais pas de connexion WiFi!!! (pourtant j'arrive à aller sur internet avec!)

Quand je fais un iwconfig, ça affiche "no wireless extension".

Que dois-je faire pour que Ubuntu la prenne en compte?

Merci pour votre aide

A voir également:

2 réponses

Messages postés
13761
Date d'inscription
lundi 2 mars 2009
Statut
Contributeur
Dernière intervention
23 janvier 2022
4 795
Bonjour,

Désolé mais ce n'est pas possible d'afficher sur ta VM les interfaces réseaux de la machine hôte.

Au niveau logique ce sont deux machines différentes, ta VM possède ses propres interfaces réseaux.
2
Messages postés
101887
Date d'inscription
lundi 16 juillet 2001
Statut
Membre
Dernière intervention
23 janvier 2022
13 390
Salut,
il faut que tu lies ta carte de VM à l'interface physique de ta carte wifi, elle sera vue comme une carte physiques ethernet, mais sera en réalité la carte wifi de la machine hôte.
Tu peux configurer deux cartes réseau sur ta VM, une liée à la connexion etehrnet et l'autre à la connexion wifi.
Le choix du réseau wifi se fera toujours sur la machine hôte.
0
Messages postés
211
Date d'inscription
lundi 14 août 2017
Statut
Membre
Dernière intervention
4 novembre 2021
1
Et donc pour le paramètre "mode d'accès réseau: NAT", c'est bon ?

Et si je configure en haut à droite "modification des connexions > ajouter > wifi", là dans la catéogorie "Périophérique", Ubuntu ne détecte pas ma clé usb Wifi, comme si je ne l'avais pas branché...

Que dois-je faire pour qu'elle soit validée?
0
Messages postés
101887
Date d'inscription
lundi 16 juillet 2001
Statut
Membre
Dernière intervention
23 janvier 2022
13 390 >
Messages postés
211
Date d'inscription
lundi 14 août 2017
Statut
Membre
Dernière intervention
4 novembre 2021

Non, dans ubuntu,
tu dois avoir ta carte ethernet virtuelle dans la liste des connexions
c'est dans l'hyperviseur que ça se configure les cartes réseau, là où tu vois "nat"
Tu as quoi comme hyperviseur ?
0
Messages postés
211
Date d'inscription
lundi 14 août 2017
Statut
Membre
Dernière intervention
4 novembre 2021
1
J'imagine que tu fais allusion à ceci quand tu parles de l'hyperviseur ?

https://img-19.ccm2.net/OynOUbUIOM9oS_lKTQSURbdSAto=/153e5c6a3320478ba397ca276fd823d1/ccm-ugc/img.png
0
Messages postés
101887
Date d'inscription
lundi 16 juillet 2001
Statut
Membre
Dernière intervention
23 janvier 2022
13 390 >
Messages postés
211
Date d'inscription
lundi 14 août 2017
Statut
Membre
Dernière intervention
4 novembre 2021

Oui,
Virtualbox en fait, pour être précis.
tu peux mettre ta carte réseau 2 en bridge avec ta connexion wifi par exemple.
0
Messages postés
211
Date d'inscription
lundi 14 août 2017
Statut
Membre
Dernière intervention
4 novembre 2021
1
Ah oui effectivement, ça marche! :) merci à toi!

Par contre, quand je fais un iwconfig, ça m'affiche ça:

lo              no wireless extensions.
enp0s3 no wireless extensions.
enp0s8 no wireless extensions.


Sur Ubuntu, quand je vais en haut à droite, sur les deux petites flèches, il me dit que j'ai deux réseaux Ethernet. Du coup, comment configurer ma connexion wifi?
0