Formule avec des noms d'onglets [Résolu/Fermé]

Signaler
Messages postés
25
Date d'inscription
vendredi 31 mars 2017
Statut
Membre
Dernière intervention
15 mai 2019
-
Messages postés
25953
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
10 avril 2021
-
Bonjour,

J'ai un tableau composée d'une dizaine de feuilles.
Les feuilles sont nommées de la manière suivante :
Bilan ; Produit 1 ; Produit 2 ; Produit 3 ; etc.

Sur ma feuille "Bilan", j'ai le tableau suivant :
BILAN
Coût 1 ; Coût 2 ; Coût 3 ; etc.
Produit 1 1 formule qui va rechercher dans la feuille "Produit 1" mon Coût 1
Produit 2 1 formule qui va rechercher dans la feuille "Produit 2" mon Coût 2
Produit 3 1 formule qui va rechercher dans la feuille "Produit 3" mon Coût 3
Etc

Ma question est la suivante :
Si ma formule est de ce style =RECHERCHEV($E$3;'Produit 1'!$1:$1048576;3;FAUX), est-ce qu'il est possible de rendre le critère 'Produit 1'! par quelque chose de plus général afin de pouvoir appliquer la formule plus facilement ?
Car si je crée un Produit 4, je ne peux pas appliquer la formule sans changer ce critère...
J'espère avoir été assez clair...

Merci d'avance pour votre temps !

A voir également:

2 réponses

Messages postés
579
Date d'inscription
mardi 10 août 2010
Statut
Membre
Dernière intervention
11 novembre 2018
302
Bonjour,

En utilisant la fonction INDIRECT, peut-être?

En admettant les noms des onglets dans la colonne A, à partir de la cellule A2.
Et toujours en admettant que le résultat à obtenir se situe dans la cellule A25 de chaque onglet.

Cette formule devrait te permettre de réaliser ce que tu désires :

=INDIRECT($A2&"!$A$25")


A incrémenter vers le bas...

Bonne journée
Messages postés
25
Date d'inscription
vendredi 31 mars 2017
Statut
Membre
Dernière intervention
15 mai 2019

Merci pour ta réponse mais quand je mets cette formule, cela m'indique #REF!...
Mais en utilisant la solution de Vaucluse, j'ai rajouté des "" autour de A2 et ça a marché !
Messages postés
25953
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
10 avril 2021
5 866
Bonjour

cette formule

=RECHERCHEV($E$3;INDIRECT("'"&A2&"'!1:1048576");3;FAUX)

ira chercher la valeur de E3 dans la feuille dont le nom est inscrit en A2...si vous respectez bien tous les signes aux bons endroits!

et pour anticiper la formule dans des lignes vides écrivez plutôt:
=SIERREUR(RECHERCHEV($E$3;INDIRECT("'"&A2&"'!1:1048576");3;FAUX);"")

cela évitera des affichages d'erreurs du type #REF

crdlmnt
Messages postés
25
Date d'inscription
vendredi 31 mars 2017
Statut
Membre
Dernière intervention
15 mai 2019

Merci Vaucluse encore une fois pour ton aide ! Ca a marché !
Je ne connaissais pas cette formule, c'est génial !
Messages postés
25953
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
10 avril 2021
5 866 >
Messages postés
25
Date d'inscription
vendredi 31 mars 2017
Statut
Membre
Dernière intervention
15 mai 2019

Pas de quoi
je passe le sujet en résolu
bonne route
crdlmnt