Excel: insertion nom onglet dans formule [Résolu/Fermé]

Signaler
Messages postés
2
Date d'inscription
vendredi 25 juin 2010
Statut
Membre
Dernière intervention
25 juin 2010
-
 joul -
Bonjour,

Après avoir lu beaucoup de posts, je n'ai pas trouvé la solution à mon problème.
Je souhaite configurer une fonction recherchev qui irait rechercher mon résultat dans un onglet sachant que je souhaite utiliser l'onglet comme variable.

j'ai plusieurs onglets qui sont formaté de la même manière, je souhaite compiler dans une feuille à part le résultat de chaque onglet. La fonction recherchev que je souhaite utiliser est donc presque identique à chaque fois, sauf que je voudrais ne pas avoir à faire un "remplacer par" systématiquement.

J'ai mis le nom des onglets en liste à gauche (colonne B) et les formules correspondantes à droite (colonne C). La valeur de référence est en C2. La plage où se trouve la valeur souhaitée dans chaque onglet est N19:O35, colonne 2.

Voici ma formule:
=Recherchev($C$2;B4&"!$N$19:$O$325";2;0)

Ca ne marche pas...

Pouvez-vous m'aider ?



A voir également:

1 réponse

Messages postés
1584
Date d'inscription
vendredi 24 juillet 2009
Statut
Membre
Dernière intervention
30 juin 2013
761
bonjour,

il faut renvoyer la chaine de texte de la référence via INDIRECT :
=Recherchev($C$2;INDIRECT(B4&"!$N$19:$O$325");2;0)

sachant que si il y a des espaces dans le nom des feuilles il faut rajouter des '

=Recherchev($C$2;INDIRECT(" ' "&B4&" '!$N$19:$O$325");2;0)
(enlever les espaces qui encadrent les ' qui ne sont là que pour la lecture de la formule sur ce post)
Si vous n'avez besoin de rien, demandez-moi.
11
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 65492 internautes nous ont dit merci ce mois-ci

Messages postés
2
Date d'inscription
vendredi 25 juin 2010
Statut
Membre
Dernière intervention
25 juin 2010

Super !
Et comment faire si il y a un "'s" (s apostrophe) dans mon nom d'onglet ?

Merci encore
Messages postés
1584
Date d'inscription
vendredi 24 juillet 2009
Statut
Membre
Dernière intervention
30 juin 2013
761
Il faut que la référence de texte comporte deux ' soit aujourd'hui doit être écrit en référence aujourd''hui''hui (il s'agit de 2 fois le caractère ' et non pas du guillemet...)
donc il faut remplacer dans la chaine de B2 les ' par deux ''....)
=RECHERCHEV($C$2;INDIRECT("'"&SUBSTITUE(B4;"'";"''")&"'!$N$19:$O$325");2;0)
(là il n'y a plus d'espaces...)
Merci !!!!! c'est top, ça marche