Addition de cellules sans doublon

[Résolu/Fermé]
Signaler
Messages postés
35
Date d'inscription
jeudi 14 janvier 2016
Statut
Membre
Dernière intervention
22 janvier 2018
-
Messages postés
35
Date d'inscription
jeudi 14 janvier 2016
Statut
Membre
Dernière intervention
22 janvier 2018
-
Bonjour,
Dans une colonne j'ai des n° de bon représentant des commandes.
10;11;12;12;13;14...
Le problème c'est que je peux avoir deux même n° de bon représentant des articles différents sur la même commande.
Je voudrais savoir le nombre de commande (dans l'exemple ci dessus 5 et non 6).
Merci.

2 réponses

Messages postés
16526
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
22 octobre 2021
3 231
Bonjour
le n° de commande dans A1:A30

=SOMMEPROD(1/NB.SI(A1:A30;A1:A30))
Formule matricielle à valider par « ctrl+maj+entrée » (et non directement par « entrée »), le curseur clignotant dans la barre de formule. La formule est alors encadrée automatiquement par des accolades : { formule }
Messages postés
8539
Date d'inscription
dimanche 13 juin 2010
Statut
Membre
Dernière intervention
20 juillet 2021
1 704
Bonjour Michel,

Bien vu, mais le PROD n'est pas nécessaire :
=SOMME(1/NB.SI(A1:A30;A1:A30))
en matriciel fonctionne aussi.

Cdlt
Patrice
Messages postés
35
Date d'inscription
jeudi 14 janvier 2016
Statut
Membre
Dernière intervention
22 janvier 2018
12 >
Messages postés
8539
Date d'inscription
dimanche 13 juin 2010
Statut
Membre
Dernière intervention
20 juillet 2021

Que de solutions...
Et cela fonctionne
Merci.
Messages postés
8539
Date d'inscription
dimanche 13 juin 2010
Statut
Membre
Dernière intervention
20 juillet 2021
1 704
Bonjour,

Dans une autre colonne :
=NB.SI($A$1:$A1;A1)=1

à tirer vers le bas
Puis faire la somme de cette colonne