Automatiser remplissage par appel d'une base de données

[Résolu/Fermé]
Signaler
-
Messages postés
26233
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
20 octobre 2021
-
Bonjour,

Après de multiples recherches je n'ai pas trouvé si ce que je veux faire est possible dans Excel.

Dans mon fichier j'ai 2 feuilles, une servant de base de données/répertoire et l'autre de fichier synthèse.
Dans ma base de données j'ai sur chaque ligne, le Nom (colonne A), Prénom (B), Adresse (C), etc
En gros je voudrais en remplissant une case A1 de ma feuille synthèse par exemple que si la correspondance se fait avec une cellule en A8 de ma base de données, les colonnes B, C, D etc de mon fichier synthèse se remplissent automatiquement avec les infos correspondant à A8 (donc B8, etc).
Avec une cellule donnée j'y arrive mais ce que j'aimerais c'est que si je met A6 ça fonctionne, A14 ça fonctionne, etc.

Petit exemple pour essayer d'être parfaitement clair :

si A=nom_x alors B,C,D,E,F = (B,C,D,E,F)_x

Merci d'avance de votre aide

1 réponse

Messages postés
26233
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
20 octobre 2021
6 089
Bonjour
à adapter
pour une valeur cherchée dans la colonne A de la base de données feuil1, et un nom à chercher dans la cellule A2 de la feuil2

en B2 feuil2!
=RECHERCHEV($A2;Feuil1!$A:$F;2;0)
pour ressortir la valeur de B ....;3;0) pour C ....;4;0) pour D etc...

Excel >=2007:
=SIERREUR(RECHERCHEV($A2;Feuil1!$A:$F;2;0);"")
vous pouvez rajouter un texte entre les guillemets qui s'affichera si erreur

Excel avant 2007:
=SI($A2="";"";RECHERCHEV($A2;Feuil1!$A:$F;2;0))

crdlmnt

vous pouvez compléter pour éviter un affichage d'erreur si A2 est vide:




La qualité de la réponse dépend surtout de la clarté de la question, merci!
Merci beaucoup de cette réponse qui m'est très utile
Messages postés
26233
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
20 octobre 2021
6 089
Pas de quoi
si elle vous convient, passer le sujet en résolu
(en dessous du titre)
bonne route
crdlmnt