Somme.si avec somme plage variable !! [Résolu/Fermé]

Signaler
-
 ma -
Bonjour,
Je souhaite faire une somme si mais avec une plage somme variable !!
Exemple :

Pdt janvier fevrier
Pomme 5 9
Orange 8 4
Fraise 1 7
Pomme 6 3
orange 7 2
Pomme 9 7

Je souhaite choisir Pomme et janvier et Excel me calcule la somme si de pomme sur colonne janvier. et si je change la seceltion en fevrier la somme si change de colonne automatiquement pour aller chercher dans le colonne du mois de fevrier.

A noter que le tableau sera une extraction d'une base et je peux pas figer les noms des colone ni son emplacement, càd que la fois suivante le tableau ressmplera pas exemple à :
Fruit Mars juin decembre
Pomme 4 2 7
Orange 8 5 6
Fraise 9 4 1
Pomme 1 6 8
orange 6 7 4
Pomme 7 1 5

et donc la formule doit s'adapter.

Merci d'avance pour votre preciseuse aide.

2 réponses

Messages postés
25767
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
22 janvier 2021
5 738
Bonjour

exemple à adapter
  • en A, titre de colonne en A1, produits en A2:A100
  • en B1,C1,D1,E1 les noms de mois
  • en F1 le nom du produit cherché
  • en F2 le nom du mois cherché

les écritures sont identiques aux liste et titre du tableau intial

=SOMME.SI($A$1:$A$100;F$1;DECALER($A$1;;EQUIV($F2;$B$1:$E$1;0);100))


le dernier 100 est la hauteur du champ et doit donc correspondre au nombre de lignes de l'adresse en début de formule

crdlmnt
Excellent et merci beacoup pour ton aide
@ Vaucluse

merci beacoup pour ton aide.