Test si valeur dans une plage

[Résolu/Fermé]
Signaler
Messages postés
223
Date d'inscription
samedi 24 novembre 2012
Statut
Membre
Dernière intervention
28 juillet 2021
-
Messages postés
26206
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
29 septembre 2021
-
Bonjour,

Je souhaite effectuer le traitement suivant dans excel (sans passer en VBA) :

- j'ai des valeurs dans la plage B1:B10
- je souhaite savoir pour chacune des valeurs de cette plage si elle se trouve dans la plage C1:C20.
- cela peut se matérialiser soit par une croix mise dans la adjacente en A1:A10 ou par la mise en couleur de la case B1:B10.

Merci pour votre aide


A voir également:

1 réponse

Messages postés
577
Date d'inscription
jeudi 22 novembre 2007
Statut
Membre
Dernière intervention
17 juillet 2018
95
Salut,

tu peux mettre en A1 (puis tirer vers le bas) :
=SI(ESTERREUR(EQUIV(B1;$C$1:$C$20;0));"";"x")


a+
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 42674 internautes nous ont dit merci ce mois-ci

Messages postés
26206
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
29 septembre 2021
6 072
Bonjour
au plus simple , à tirer vers le bas:
=SI(NB.SI($C$1:$C$20;B1);"vrai";"")

ou MFC par formule
sélectionner B1:B10
MFC "utiliser une formule"
=NB.SI($C$1:$C$20;B1)
Formater et ok:ok
crdlmnt