Formule de taux de réussite par type de poste

Résolu/Fermé
Signaler
Messages postés
21
Date d'inscription
samedi 23 mai 2015
Statut
Membre
Dernière intervention
7 décembre 2021
-
Messages postés
21
Date d'inscription
samedi 23 mai 2015
Statut
Membre
Dernière intervention
7 décembre 2021
-
Bonjour,

Je viens de réaliser plusieurs tableaus et j'ai besoin d'aide pour terminer la formule ci-dessous:

=SI(SIERREUR(SOMME.SI($B$3:$B$13;$A34;C$3:C$13)/(5*(NB.SI.ENS($B$3:$B$13;$A34)));"")=0;"";SIERREUR(SOMME.SI($B$3:$B$13;$A34;C$3:C$13)/(5*(NB.SI($B$3:$B$13;$A34)));""))

Mes critères de calculs sont les suivants:
- Prendre en compte du type de poste
- Prendre en compte la note au questionnaire
- Ne pas inclure (comme ici) les postes n'étant pas notés sur ce critère (j'ai plusieurs colonnes avec différents questionnaires. EN gros c'est cette partie là qui me pose problème.

Je ne trouve pas de solution pour trouver une prise ou non prise en compte d'une cellule vide ou équivalente à 0 afin d'avoir une belle petite formule juste.


Merci d'avance ;)
A voir également:

4 réponses

Messages postés
8539
Date d'inscription
dimanche 13 juin 2010
Statut
Membre
Dernière intervention
20 juillet 2021
1 733
Bonjour,

Essaies de mettre un grand miroir face à ton écran pour
qu'on puisse voir à quoi ressemble ton fichier.

Si tu n'as pas de miroir, déposes un fichier avec des commentaires
sur https://www.cjoint.com/ ou sur https://mon-partage.fr/
et mets le lien obtenu dans ton prochain message.

Tuto : Comment utiliser C.joint.fr
1
Messages postés
21
Date d'inscription
samedi 23 mai 2015
Statut
Membre
Dernière intervention
7 décembre 2021

Bonjour,


Tout d'abord merci de votre réponse, et, voici le lien vers cjoint :

https://www.cjoint.com/c/GFbmqn3VUcf


À bientôt :)
0
Messages postés
26407
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
23 janvier 2022
6 186
Bonjour
en attendant Patrice, quelques questions qui pourront peut être lui servir
on a (du moins moi) un peu de mal à comprendre les arguments de la formule en B34, et pas conséquent un peu de mal aussi à vous aider
quel raisonnement voulez vous mettre en place,et notamment le 5* ????
et qu'est ce qui ne convient pas comme résultat dans le tableau inférieur?
à vous lire
crdlmnt
0
Messages postés
21
Date d'inscription
samedi 23 mai 2015
Statut
Membre
Dernière intervention
7 décembre 2021

Bonjour,

1/ Les SIERREUR ne sont uniquement là que pour des raisons esthétiques (je n'aime pas avoir des messages d'erreurs de partout ^^), n'y prêtez donc pas attention.

2/ Les chiffres de 1 à 5 correspondent à des notes.

3/ Les différentes thématiques doivent être pouvoir utilisées indépendamment les unes des autres donc, comme inscrit, une ligne du tableau ne sera pas nécessairement rempli en entier.

Et donc, la formule doit pouvoir me générer un pourcentage de réussite par rapport aux notes, le type de poste d'une personne et la thématique abordée.

La division par 5 n'est là que pour arriver à un pourcentage.

Les résultats ne me convenant pas sont par exemple celui en C34.
Celui-ci est à 50% alors qu'il devrait être à 100%.

Et en fait, le problème vient de la formule qui compte les types de postes mais ne cherche pas les cellules vides ou non dans la colonne étudiée.


Auriez-vous besoin d'autres précision ?



En espérant vous relire (et ne pas vous avoir désespéré ^^)

Merci :)
0
Messages postés
26407
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
23 janvier 2022
6 186
Pas de quoi désespérer, mais pas de quoi comprendre non plus
à tout hasard, j'arrive à 100% en C34 avec cette formule (en éliminant une bonne partie de la votre)

=SIERREUR(SOMME.SI($B$3:$B$13;$A34;D$3:D$13)/(5*(NB.SI.ENS($B$3:$B$13;$A34;$D$3:$D$13;"<>")));"")

NB.SI.ENS ne compte que les lignes dont le code A34 est en B et qui ne sont pas vides en D

c'est peut être ce que vous cherchez ??? (va savoir ;-))

crdlmnt
0
Messages postés
21
Date d'inscription
samedi 23 mai 2015
Statut
Membre
Dernière intervention
7 décembre 2021
>
Messages postés
26407
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
23 janvier 2022

YES!!! Merci beaucoup :)

J'ai simplement établie une correction et c'était parfait.

=SIERREUR(SOMME.SI($B$3:$B$13;$A28;C$3:C$13)/(5*(NB.SI.ENS($B$3:$B$13;$A28;C$3:C$13;"<>")));"")

Merci à vous deux, je peux désormais clore le sujet :)
0