Macro recherche dans une feuille selon son nom

Résolu/Fermé
Bikouu
Messages postés
2
Date d'inscription
vendredi 26 mai 2017
Statut
Membre
Dernière intervention
26 mai 2017
- 26 mai 2017 à 11:34
f894009
Messages postés
16496
Date d'inscription
dimanche 25 novembre 2007
Statut
Membre
Dernière intervention
24 mai 2022
- 26 mai 2017 à 14:53
Bonjour à tous,

J'aimerais créer un fichier Excel qui comporte plusieurs feuilles avec un nom de fournisseur pour chaque feuilles.

Je sollicite votre aide pour mettre en place une macro qui va me récupérer un tarif dans une des feuilles selon le nom du fournisseur que je saisie.

Merci d'avance pour votre aide ☺

2 réponses

f894009
Messages postés
16496
Date d'inscription
dimanche 25 novembre 2007
Statut
Membre
Dernière intervention
24 mai 2022
1 633
26 mai 2017 à 12:05
Bonjour,

Si vos donnees sont bien ordonnees, pas besoin de macro, une formule recherchev doit le faire
0
titeufdu89
Messages postés
371
Date d'inscription
samedi 28 juillet 2012
Statut
Membre
Dernière intervention
4 mars 2019
36
26 mai 2017 à 12:31
Bonjour,

Si tu cherches à aller récupérer dans info dans un feuille dont le nom figure dans une cellule de ta page de destination je te conseillerais alors d'utiliser la fonction RECHERCHEV() accompagnée de la fonction INDIRECT()

Ex :
Je suis en page 3, j'ai le nom de mon fournisseur en A1 et je souhaite faire apparaitre en C1 le prix de l'article notifié en B1.
Admettons que dans ma feuille de prix fournisseur les articles sont saisis dans la colonne A et les prix dans la colonne C (3ème colonne).

Voici la formule taper dans la case C1 de la page 3

=RECHERCHEV(B1;INDIRECT("'"&A1&"'!A:C");3;0)

Il te suffit de remplacer les coordonnées des cellules et de la plage de recherche par celles de ton fichier et tu devrais pouvoir obtenir le résultat escompté sans avoir a utiliser de VBA (...si j'ai bien compris ta demande... dans le cas contraire, pourrais tu poster ton fichier ça aiderait a comprendre plus aisément tes besoins)

Bonne journée
0
Bikouu
Messages postés
2
Date d'inscription
vendredi 26 mai 2017
Statut
Membre
Dernière intervention
26 mai 2017

26 mai 2017 à 14:46
Bonjour,

Désolé je suis nouveau sur le forum et je n'arrive pas à poster le fichier. Pourriez-vous m'indiquer comment on fait svp.
0
f894009
Messages postés
16496
Date d'inscription
dimanche 25 novembre 2007
Statut
Membre
Dernière intervention
24 mai 2022
1 633 > Bikouu
Messages postés
2
Date d'inscription
vendredi 26 mai 2017
Statut
Membre
Dernière intervention
26 mai 2017

26 mai 2017 à 14:53
Re,
Pour transmettre un fichier,
Veillez a ce qu'il n'y ait PAS DE DONNEES CONFIDENTIELLES
il faut passer par un site de pièce jointe tel que cjoint.com

Allez sur ce site : https://www.cjoint.com/
Clic sur parcourir,
Cherche ton fichier,
clic sur ouvrir,
Clic sur "Créer le lien cjoint",
Copier le lien,
Revenir ici le coller dans une réponse...

ou
'mon partage
https://mon-partage.fr/
0