Plage de données variable dans formule Excel

Résolu/Fermé
Julien68708
Messages postés
4
Date d'inscription
vendredi 28 avril 2017
Statut
Membre
Dernière intervention
1 mai 2017
- 28 avril 2017 à 16:55
Patrice33740
Messages postés
8549
Date d'inscription
dimanche 13 juin 2010
Statut
Membre
Dernière intervention
7 mai 2022
- 1 mai 2017 à 17:52
Bonjour à tous,

Je souhaite dans la formule ci-dessous, faire varier le nom de la colonne de la plage de données (A, B, C,...) en fonction d'une variable

"=NB.SI.ENS('Database SA'!A4:A1000;1)"

Ma variable est en chiffre (Colonne A = 1)

Je souhaite que si ma variable est 3, la plage de données de ma formule est la colonne C au lieu de la colonne A

Par exemple, je veux que ça donne "=NB.SI.ENS('Database SA'!C4:C1000;1)" de manière automatique

Je sais que mon problème est très simple en VBA mais s'il y a un moyen en formule, je suis preneur

Merci par avance

Julien

2 réponses

Patrice33740
Messages postés
8549
Date d'inscription
dimanche 13 juin 2010
Statut
Membre
Dernière intervention
7 mai 2022
1 750
28 avril 2017 à 16:59
Bonjour,

Regardes la fonction DECALER()
2
Julien68708
Messages postés
4
Date d'inscription
vendredi 28 avril 2017
Statut
Membre
Dernière intervention
1 mai 2017

28 avril 2017 à 17:07
Pour la fonction décaler, il faut une colonne de base et je n'ai pas de colonne de base.
0
Raymond PENTIER
Messages postés
56076
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
18 mai 2022
17 212 > Julien68708
Messages postés
4
Date d'inscription
vendredi 28 avril 2017
Statut
Membre
Dernière intervention
1 mai 2017

28 avril 2017 à 19:11
Ta colonne de base, c'est A (ou 1) !
0
Patrice33740
Messages postés
8549
Date d'inscription
dimanche 13 juin 2010
Statut
Membre
Dernière intervention
7 mai 2022
1 750
28 avril 2017 à 19:10
Hein ????
Une colonne de base ?

Si ta variable est en B1 :
=NB.SI.ENS(DECALER('Database SA'!A4:A1000;0;$B$1-1);1)
0
Patrice33740
Messages postés
8549
Date d'inscription
dimanche 13 juin 2010
Statut
Membre
Dernière intervention
7 mai 2022
1 750 > Patrice33740
Messages postés
8549
Date d'inscription
dimanche 13 juin 2010
Statut
Membre
Dernière intervention
7 mai 2022

28 avril 2017 à 19:14
PS : plus simple :
=NB.SI(DECALER('Database SA'!A4:A1000;0;$B$1-1);1)
0
Julien68708
Messages postés
4
Date d'inscription
vendredi 28 avril 2017
Statut
Membre
Dernière intervention
1 mai 2017

1 mai 2017 à 16:53
Merci beaucoup. J'ai dû mal à comprendre le fonctionnement de cette formule mais elle marche à perfection
0